Get Orchestrator asset: You are not authenticated! Error code: 0

Hey there,

I was working on a bot and suddenly when I ran it to test, I received ‘Get Orchestrator asset: You are not authenticated! Error code: 0’.

I asked my colleagues about this and they apparently are having the same issue. This is widespread on all bots, seems to be on the ‘Get Assets from Orchestrator’ in the InitisaliseAllSettings framework.

What could have suddenly caused this and is there a fix? We are all falling behind on work ahaha.

I’ve been reading through posts like these and haven’t found any sort of solution that works for us.

So you tried…

  • Upgrading to the latest version of UiPath.System.Activities
  • Verifying the Robot’s role has the necessary Asset permissions
  • The Asset is in the same Orchestrator folder as the Robot(s)
  • Deleting and recreating the Asset
  • Deleting and recreating the Robot


Check the Orchestrator certificate as it may be recently expired or changed.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.