Activity Get Asset not working (You are not authenticated! Error code: 0)

I am going through the online training modules again and am currently on the Orchestrator for developers module.

This will impact anyone doing the course (and any other further training that uses orchestrator assets/queues etc.) unless of course this is just affecting me only.

I am using Studio CE edition 2020.10.2

Unless I roll back UiPath.System.Activities to v20.4.4. My orchestrator activities such as Get Asset do not work. I get message You are not authenticated! Error code: 0.

The current package is 20.10.1 (but many of the packages between also do not work, I haven’t tried them all)

I have seen this before but assumed it must have been resolved by now.

Does anyone have an idea why this is occuring?

Many thanks,

Practice 7 - Assets in Orchestrator (workflow).zip (11.4 KB)

1 Like

Hey @charliefik,

It is the permission issue.

First check what is the role permission assigned to your bot in orchestrator.

Then, check the Roles Tab. Open the role assigned to the robot by clicking edit.

Finally Check the required permission(View in your case) are given for assets

Hope this helps.

All the above steps are done assuming your robot is already connected to orchestrator.

Thanks

Hi Nithinkrishna,

I don’t think it is permission related. I had already given my robots full asset access

Is the workflow working for you using CE edition 2020.10.2 and UiPath.System.[Activities] 20.10.1?

Also it’s not just asset related any orchestrator activities also fail like get transaction/add queue item (which shouldn’t require any adjustment, also I believe the view permission for assets is set to true by default in the permissions anyway)

My Robots also have full queue access

The other thing that makes me think that it is not permission related is that if as I said in the initial post I roll back my UiPath.System.[Activities] to v20.4.4 then it works fine.

If it was a permissions issue surely I would have the same issue whatever package version I was using (unless older packages ignored the permissions set up)

Yes @charliefik, The workflow works fine for me :slight_smile:

Well that’s confusing! Can you tell me which version of the UiPath.System.[Activities] package you are using please.

I’m using System Activities v.20.10.1

Can you delete the Machine, robot and reallocate the same and try again ?

This is the machine I set up after deleting the previous one.

In my default folder I have created astandard robot BLPTP but it shows as available but unlicensed.

In the Robot assistant on the machine under preferences orchestrator settings you can see it says connected unlicensed.

Does anyone have any ideas. In other posts it seems to be that it’s because the domain name was not used in the orchestrator robot set up but I have done that as you can see from the screen shot.

If I try to publish from Studio to orchestrator I get the following message.

image

Also If I hover my mouse over orange dot on assistant

If I change the orchestrator URL to just https://cloud.uipath.com/ instead of https://cloud.uipath.com/charliefik/charliefik/

I still connect and am unlicensed (in orchestrator as well)

but message on assistant now says you are not authrized to perform this action when hovering over orange dot. I don’t know what else to do now

Does it work when you try to do it on the “SilverRobot”?

I might be wrong and the services of cloud orchestrator are off for me on this moment, but i think you only have one Studio license available to use. Since you are using it on the “SilverRobot” it should not license your other robot.

You could try to create a new robot with a “unattended license” and test the workflow.

Tks.

Are you sure about the Machine name you have given. Also, did you remove and try to reconfigure both robots and machine ? https://docs.uipath.com/orchestrator/docs/about-machines#section-finding-the-machine-name

And about the license, can you please check in automation cloud how many licenses are available for studio?

Hi Schirru,

I’ve had 2 licences for ages using community edition one for silver robot and one for the other one (which now doesn’t work) I’m guessing they give you 2 so you can play with multiple robots running processes.

However I rarely use the silver laptop (although I am now).

One piece of good news is that on the silver laptop I can use the ‘get asset’ activity using UiPath.System.[Activities] 20.10.1 so this isn’t the issue that I thought it was (however it doesn’t explain why the orchestrator activities weren’t working on the black machine unless I rolled back to activities 20.4.4, however that is now a secondary issue to trying to get the black machine reconnected).

Hi Deebiga,

I got the machine name from the robot assistant but here is the result from cmd

image

and here it is from the assistant preferences (Machine Name is not an editable field)

I believe the issue is with licencing (as you can see above the status is showing connected, unlicensed). On my other machine (silver robot) status shows as connected, licensed and is green.

I’ve had both machines active previously until I removed this machine and recreated it. It may be that the licence is still somehow connected to the original machine set up on orchestrator? and was not released when I removed it in order to recreate. I’ve no idea how to now release that licence.

I haven’t tried removing both robots as the silver one is now my only working robot and I don’t want to lose all access to orchestrator (can access orchestrator assets on silver machine using latest studio.activities package though so that is a plus, but not having any orchestrator access at all on this my main machine is a big minus).

In orchestrator cloud -> admin -> robots

but from home page shows no licences being used (?)

I’m going to remove the black machine and robot and start again from scratch (have done this a number of times now though without any change)

Hi Clark,

Please look at how many licenses are there in Studios Tab of the License Allocation page. You have currently pasted the Robots Tab.

OK removed black machine from orchestrator. You can see only 1 out of 2 studio licences are being utilised from this licence screen

When I create a new machine in orchestrator

and then copy the key to the robot assistant and try and connect I still get connected, unlicensed

I’ve now readded the machine and robot.

You can see that the new robot still shows as unlicensed

If I go back to the license allocation page within the tenent both licences appear to be utilised

but when trying to connect via the robot assistant it still shows as connected, unlicensed.

as it does in orchestrator

I see, can we get into a call if possible for you ?

That would be amazing thanks

Just to let you know I have also used the extended orchetrator URL

With the same results

Hi Deebiga,

As you know we reverted studio 2020.6 but that unfortunately didn’t work.

I reinstalled 2020.10.2 and was playing with the assistant.

This is what we were seeing on the opening window for assistant

and this is what we saw in preferences

With the robot appearing as connected, unlicensed.

What I did was go to the person icon and clicked sign out

Then I could see the list of processes that had been published and also that the robot was connected (green dot)

If I go to preferences in assistant now it says connected, licensed

Even better I can now access assets using the newest version of system. activities on this machine

If on the assistant if I click on sign in everything goes bad again so I’m not sure about that sign in functionality or what it’s for, but I thought you should know.

Many thanks for your help.

1 Like

For the Sign in to work, Make sure in Orchestrator -->tenant --> settings --> security enable Allow both user authentication and robot key authentication. Also, make sure your Name and email id and other details are correct in cloud.uipath.com --> Admin --> Users and groups