Get Hash Result Error

Hello,

I am currently on Assignment 1 RPA Advanced Course.
I have been having error on getting the hash result.

I noticed that when I run the single file it turns out great and I got the output needed.
But when I try to run the whole project, the error seems to be in the get hash result.(in picture)

I have check the selector and notice a pattern where it is validate when I’m on the SHA1 Online webpage, once I close the browser, the selector turns to not validate.
(I am using google chrome as default browser)

I followed the guide where I have set the WaitForReady to complete.
Currently I am not getting where I did a mistake.

Hi

Replace the value of innerText attribute in the selector with a wildcard * symbol and give a try

@adamikh96

Hi, I have replaced the value of innerText attribute like you said and I still get error.


(Please correct me if Im wrong)

Again I would like to highlight that when Im on the SHA1Online webpage the selector for each process in get hash result is green(validate), but when I close the browser before running the project it is labelled red(not valid).

hi, try Get Full Text activity instead :), it should work!

1 Like

It’s obvious because only when the elements are active which means when page is opened only then the selector will be valid showing green Color
Else will be in red meaning element is not active

@adamikh96

So make sure your web page is opened when this activity is about to execute

And now there are two things to be considered
Either the selector must be made more stable Ina way by clicking on OPEN IN UI EXPLORER and include stable attributes to the selector
Or
Us GET ATTRIBUTE instead of GET TEXT and mention the attribute as innerText so that the value of that attribute can be obtained as a string output
Or use a GET FULL TEXT of screen scrapping method

Cheers @adamikh96

I have tried using the GET FULL TEXT activity and changed the innertext to a wildcard *
and still get error as shown below

Manage to get the client information in the SHA1 textbox, but could not hash the client information

Try without innertext, it could be it.

I have tried to run the project using GET FULL TEXT without innertext and I still get error.

As I said earlier, I manage to get the client information in the SHA1 textbox webpage, but no action on hash button click to get the hash result.

I have already set a click activity on the hash button, but it seem like its not working on my machine.

PS: Im using google chrome

I tried to do same situation like you have


this is my selector for click

This is my selector for get full text activity
And its working right.
Can you see any difference from your solution?