Assignment No 1 - Workflow faulted at 'Get Text' for SHA1 result

activities
academy2

#1

Hi There,

I am again having a hard time in completing assignment no 1. Everytime the workflow gets faulted at ‘Get Text’ activity for sha1 result. However when i run and test the associated .xaml file individually, it works fine. I don’t see any change in the selectors as well. If anybody could help, it would be great.

AssignmentNo1_REFramework_RM.zip (1.2 MB)

Thanks,
Rammohan B.


#2

Hi @Rammohan91,

image

i checked with you code output getting exactly, can you check it again. Refer above image

Regards,
Arivu


#3

Hi,
@Rammohan91

How did you resolved this ?? I am stuck at same error.

Thanks in advance.


#4

Hey @Srishti_Agarwal,

I used a ‘Delay’ activity with delay of 3 Seconds, followed by ‘Element Exists’ with the selector of the Hashcode and then the ‘Get Text’ activity to get the hashcode. Also, change the WaitForReady property of Get Text to ‘Complete’.

Thanks,
Rammohan B.


#5

I’m having the issue listed here but am unable to get it work with the suggested workarounds. I’m able to use the Ui Explorer to highlight the target of Get Text and that’s working as intended. Is the solution really just to wait longer? There’s no way this web page is taking longer than 30 seconds to load when generating the hash. I have also set up the part of my program that reads from the hashing page in a way that I can run it solo. When doing that I’m able to get the expected functionality; however, when trying to use that code in my main workflow it doesn’t work. What could be going wrong here?


#6

I had the same problem and I updated by selector based on this forum discussion Level 3 Exercise 2 Get Text for Hash Number SOOOO Slow!
After that the Get Text worked for me.