**Get Exchange Mail Messages: The Autodiscover service couldn’t be located** 2023

Dear UiPathers

Take a look at my attached picture, I keep getting the error Get Exchange Mail Messages: The Autodiscover service couldn’t be located even when I am using “Send Outlook Mail Message”. Any idea why this might be?

I have looked at the following links, but they seem to be outdated, so I don’t know if the answers are applicable anymore to my problem. None of the answers given resolved my issue.

(Get Exchange Mail Messages: The Autodiscover couldn't be located)
(Get Exchange Mail Messages - The autodiscover service could not be located)
(Get Exchange Mail Messages: The Autodiscover service couldn't be located)
(Error: ESend Exchange Mail Message: The Autodiscover service couldn't be located)

Are you using M365 or are you using an old Outlook Client?

Could you try putting your email Account in “Input”, “Account” and try again?

Dear Nairda

I am using Outlook 2016 which is a part of the Microsoft Office 2016 package.

Regarding your second suggestion, I just tried to include my mail again in “input” and “account” and it seems to not work.

Autodiscover means from my understanding, that in the execution of your process, UiPath Studio can not connect or talk to the Outlook Client API. I believe it’s either a permission/group policy thing or possibly if you had more than one Outlook Client installed.

Are you on a private Notebook/Computer or on a company device?
Do you have more than one Outlook Client installed - possibly on other user profiles?

Dear Nairda

I am on a company device, however, we are using a remote desktop. We only have one outlook client installed and the only client is Outlook 2016.

I have tried and debugging and experimenting, do you think the error could be in my assets in Orchestrator? Does that have to do anything with Outlook 2016?

You didn’t use any asset in your SendOutlook Activity in the screenshot, so it shouldn’t be the problem.

I’m not sure as I have no experience with Outlook 2016 Client, but check if Settings in Outlook Client are correct in Trust Center, Programmatic Access

You might need admin-rights to change settings there.
However I am not sure if that actually overwrites active policy settings, if it is blocked by policy through your IT.

Dear everyone

After further debugging and experimenting, I think the error lies in my assets.

I get the following error…
“Could not find the asset ‘j000166’. Error code: 1002; Asset name: j000166”

This is my asset for j000166

Can someone guide me to how I see my asset on UiPath Studio, so I can succesfully say if this is why my original error is occuring or not? Many thanks in advance!