Generate yearly roport

robot
studio
certification

#1

Hi there I’m running the generate e yearly report and my system runs smoothly through the first transaction taken from the queue but starts to run into problems through the second one. Each time thr error is different

Fails to find ui elements
Or can’t select save option

Can anyone please let me know on how I can resolve this


#2

Hi @Damian123!

It’s about the selectors. Re-do these activities with a robust selector


#3

Thank you il give that a try it’s just strange to me that the first transaction run is perfect

Will keep you updated


#4

Maybe you have something harcoded, like the title of the page.
In the first transaction, the title is right but in the second the title is already wrong. Look at that first


#5

Il take a look but seems to beget stuck on the save as element the title is not available for that

Could it be that at the end of the process when I set transaction status that it’s not clearing thr existing outputs?


#6

Right there you have to open the UiExplorer to select the corresponding element and selector.

I didn’t understand your question… :confused:


#7

Sorry about that I have rebuilt the creat yearly report and I’m having thr same issue 1st transaction success second transaction got suck on download monthly report

Can I send it to you so you can take a look I really can’t figure this out?


#8

It got as far as to download aprils transactions


#9

Could you please share the workflow


#10

System1_CreateYearlyReport.xaml (39.6 KB)


#11

Error


#12

You dont need to do the actions in both the branches of the if
image
and you should correct the selector for your element exist activity as well.


#13

Thank you il give that a try should it run through all transactions after that because as I said before it runs the first transaction smoothly and then as soon as it loops and does transaction 2 it get stuck?


#14

i think it dosent get stuck rather slows down. you can do some tweaks and speed it up.
See here how to:


#15

Thank you Nadim il give that a try and let you know. I also thought it could be slowing down to a point where it hangs for minutes before selecting

Another problem I encountered wats in the set transaction status - > SUCCESS the log msg seems to stop the process as well is the log msg needed for a 100/100 mark?


#16

those tweaks should fix it.

that should not be the case. its an assign and should not stop your process.


#17

Alright so i tried rebuilding the create yearly report portion you suggested and with no luck if i run the sequence on its own it works great as soon as i put it in the create yearly report sequence it doesn’t even run the select3 Capture create%20yearly%20report1 drop down and save as


#18

Whent through smooth on first transaction and got stuck again on the second one :cry:

It hangs for 1 min or so and starts over again I


#19

Have you enabled SimulateClick for the arrow and save as click?
Also make the WaitforReady as none and try


#20

I did do that yes now I’m going through all selectors and replacing the title of the elements just with URL