FTP not working the download

Hello friends,
@rkelchuri, @Ninett_Panfir, @Rammohan91, @balupad14, @Florent_Salendres, @vvaidya, @Palaniyappan, @ClaytonM, @vvaidya

I testing the FTP capabilities of UIPath and wrote a small script that tries to upload a file to a public FTP server, list the folders on the server and download a file. On all stages I get the message Connection is OK when I click on test connection. When I run the script I used to get no errors, yet the FTP actions are not performed. I was not able to upload, download a file or get a directory listing. However, now I also get an error regarding an invalid constructor (please see the attached screenshot).

The message, “Connection is OK” hinted me that the problem might be related with how I specify the local and remote paths. However, after browsing the forum and trying out various approaches such as (./upload/filename , /upload/filename, ftp://sitename/upload/filename etc.) they all failed. What might be the issue and how can it be resolved? I am attaching my xaml file to this post.

Note that Filezilla performed these FTP tasks without an error and I use UIPath Community Edition if this is relevant at all. I also tried putting the FTP actions inside an FTP Session container. I use a public test FTP server and users can upload into the /upload directory and download from /download directory.

The credentials and server URL/port for the public FTP server are below:
User name: demo-user
Password: demo-user


Main.xaml (7.2 KB)




May I know what is this FileZilla

Well usually when I was trying for FTP Activities even I faced the same there were no errors but ftp didn’t return any files or uploaded files
So what we did we took the alternative way of approach
We use one drive folder or a shared folder
Where any file from one drive can be accessed from our system if we have the access to that on drive or shared folder so that we can sync that folder to our machine

Cheers @CamiCat


Hi @CamiCat

I have just tried to list all the files in the upload directory and it seems to have worked just fine:

I do have a small issue with uploading the file though, I get

RemoteException wrapping System.AggregateException: One or more errors occurred.  ---> RemoteException wrapping FluentFTP.FtpException: Error while uploading the file to the server. See InnerException for more info.  ---> RemoteException wrapping FluentFTP.FtpCommandException: This file is banned on server!; Cannot STOR. No permission. 

I am using the latest version of the FTP package:


Thank you so much @loginerror,

can you please attach the workflow you used?
Thank you,

Sure, here it is:
FTPTest.zip (2.2 KB)

It was made on the latest Studio CE 2019.7.

1 Like

Thank you so much.
Can you please add the piece for the download of the file?
Thank you,
Cami :slight_smile:

Sure, and actually with also working upload this time:
FTPTest.zip (79.7 KB)

It will first download all the files and then upload one new one.


Thank you so much @loginerror.
Are you able to do the upload?
Thank you,
Cami :slight_smile:

Yes, it worked when I used one of the files that were already uploaded.

See the Upload activity in the above workflow. It should work :slight_smile:


i’m using the Uipath Studio 19.7 but the uipath.ftp version still uipath

1 Like