FTP upload, download not working; the site works well with Filezilla


#1

Hello,

I testing the FTP capabilities of UIPath and wrote a small script that tries to upload a file to a public FTP server, list the folders on the server and download a file. On all stages I get the message Connection is OK when I click on test connection. When I run the script I used to get no errors, yet the FTP actions are not performed. I was not able to upload, download a file or get a directory listing. However, now I also get an error regarding an invalid constructor (please see the attached screenshot).

The message, “Connection is OK” hinted me that the problem might be related with how I specify the local and remote paths. However, after browsing the forum and trying out various approaches such as (./upload/filename , /upload/filename, ftp://sitename/upload/filename etc.) they all failed. What might be the issue and how can it be resolved? I am attaching my xaml file to this post.

Note that Filezilla performed these FTP tasks without an error and I use UIPath Community Edition if this is relevant at all. I also tried putting the FTP actions inside an FTP Session container. I use a public test FTP server and users can upload into the /upload directory and download from /download directory.

The credentials and server URL/port for the public FTP server are below:
URL:demo.wftpserver.com
User name: demo-user
Password: demo-user
Port:21

Thanks

Main.xaml (7.2 KB)

filezilla_remoteftp_conn_ok


#2

Any ideas?