FOR PROFI , interesting problem send of hotkeys

uiautomation
studio
hotkey

#1

Hello, please help, the success of my project depends on this.
Did not find the solution options on the forum, more convinced that I’m doing the right thing.
The problem is something else
I use UiPath community edition 2018.1.2 on the local machine
PROBLEM: When I want to send a hotkey (ctrl+a,ctrl+c). As a result, I get the final letter from the hotkey that was entered into the field in which I wanted to apply it and the lack of result.
THE MOST AWESOME: after trying to enter a hotkey with a combination (ctrl) I after the execution of the process, this key seems to be jammed on the keyboard and works after the process until I
Example of the result I attach to the picture
1122

HELP HELP HELP
without hot keys I do not implement my project


#2

Hi,

Are you using the Recording Wizard? Have you tried running the process that you recorded and does it type the “a” instead of select all?
Also, could you provide screenshots of your workflow, which might help identify the problems? (It should have added a “Send Hotkey” activity)… most of the time you must go in and fix many things after you have recorded something.

This is just my opinion, but the Recording tools are useful when you are first starting out for “learning” but should not be used mostly for UiPath development. If you can go in and manually change your “TypeInto” activity to type the below example, it should perform the equivalent of the hotkey, as well::

TypeInto "[d(ctrl)]a[u(ctrl)]"
// with a 20sec key delay in properties

Hope this is helpful.

Regards.


#3

@ClaytonM Hi, thanks for your answer.
I use master recorder, manual method (type into, send hotkey and “[d(ctrl)]a[u(ctrl)]”)
I ran them and they injected “a”
I also ran your example and received only “a”
Attention: After using all the methods, “a” was entered and the process terminated. After the completed process on the computer, the button “ctrl” was active and turned off only after clicking

I attach your version and the standard one. All of them simply enter “A”