Flow Decision - Step by step Debug Run - Visual Issue

Hello Everyone,

I have noticed that when i am using the step by step debug run mode, i am not having the visual when it reaches the flow decisions inside a flowchart container.


I am using the 2022.10.3 Studio version and i was wondering if it could be a bug as it was functional in previous versions of the Studio.

Can anyone share something on that ? Thank you.

1 Like

Hi, It is a functional thing.
It has been the same even in the previous versions. Also you can see a small blue coloured line when you run in step by step mode when it reaches the flow decision. The difference is very negligible though

with Control in flow decision :
With control not in flow decision :

Hope it helps.

Hello Vishnuvarthan,

Thank you for having a look at the issue.

I am aware of the blue outline however it is not working on the flow decisions and flow labels.

I am sharing a run.

Info : The run has reached the flowchart breakpoint (Blue outline shown)

One Step into - Neither the Start or “Is Traité” flow decision has the blue outline.

One more step into - it reaches an invoke method down the flowchart.

Just an idea where the invoke method is located in the workflow:

After the right sequence and step into clicks - It shows the blue outline.

It is just bypassing the flow decisions but it runs correctly.

Super strange .

It works on my studio but the difference is probably with the studio versions.


Can you maybe restart the studio and see if it helps?

Indeed, that’s strange.

Restarting studio did not work.

I have tried a test on a newly created process. It works there.

1 Like

Looks very Random though - Activity Outline Missing During Debug
Do you know if the new process and old process have similar packages and its version?

Yes, they have the same versions.

Test File

Current file

1 Like

Looks to be a random issue then :frowning:

No worries. Thanks for helping though.

1 Like

Have tried to replicate this on our side but every time I get the cursor and the blue indicator for the current step.

Can you maybe share the project where the issue is visible? Also, I recommend upgrading to 22.10.4 or 22.12 as we have modified some of the heights and borders of the activity.

1 Like

Hello alexandru,

I upgraded to 22.10.4 but i am still facing the issue. It’s like it’s having an issue with this project only.

I’ll check if i can share the workflow.

1 Like

Hello @alexandru, @vishnuvarthanp

I managed to perform some tests and here are my observations :

  • The step by step does some weird transitions when there are multiple flow decisions connected with no activity in between.

  • If we place some activities in between the flow decisions, it will still not show the transition marker on the flow decision but we will be able to see the flow on the True/False label.

I’m attaching a simple process for you to test and a video sample of the run with the weird transitions.

Main.xaml (13.0 KB)

1 Like

Hey @hans.gunnoo

I gave it a test on the latest Community 2022.12 version and System 22.10.4 package and at least the blue outline is working correctly now.

However, the behaviour where it skips to the first decision point that evaluated to true is still the case. It steps from this:

directly to this:

I’ll save this as a bug for the team to consider.

1 Like

Hi @hans.gunnoo

I tested it again on the latest Studio 23.4.0 and System 22.10.4 and it no longer reproduced.

This might mean that the issue was Studio related and an update to the newer Studio version should fix it. It could be that the fix will be included in a patch to Studio 22.10.x as well.

Hello Maciej,

Thank you for your effort in resolving the issue. I shall test it with the new version and give you a feedback.

Thanks and Regards

Hello Maciej,

I confirm the flow is now working fine.

I’m running the 2023.4.1 studio.

Thank you.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.