Facing Issues While Automating Oracle Application

studio

#1

Hi Folks / UiPath,

Hope you guys are doing well!!

I’m trying to automate an Oracle Java Application however, It’s not working fine. Sometimes It works fine and sometimes not. I’ve already gone through a few articles on the forum regarding the same but didn’t find any solution.

Problem - I’ve to enter a value in a text box named “Supplier Number” however when I execute my code it put that value in an another random text box.

Selector -

<wnd app='jp2launcher.exe' cls='SunAwtFrame' title='Oracle Applications*' />
<java name='Invoice Workbench (Payables User)*' role='internal frame' />
<java idx='2' name='Supplier NumList of Values' role='text' />

I’m not getting what’s wrong with my code. Please provide a good solution asap.

Thanks in advance.


#2

hi @vikaskulhari
In the title tag give the value as *
try to indicate the selector through UI Explorer
and ensure that you have role item on your right side and uncheck the role item
sometimes the idx value might change
Check it at once

Thanks
Ashwin S


#3

Hi @vikaskulhari,

@AshwinS2 's suggestion is quite the standard way we follow while fixing a problem like this.

You could also try this though:

  1. run the program 2 or 3 times and grab and print the selector using a “message box” activity. In my experience, some selectors change dynamically per fresh execution.
    If so, either the selectors are different at every runtime OR (this is what happened with me) the selectors repeat, as in you’d find that there are 2-3 selectors that come, sometimes this, other times something else, but it’s always amongst a particular set.

(Let me know if you want to try this one out?)

  1. The easier way, try using a “Relative Click” + “Type Into” (without indicating) combo.

Let me know incase if you need something.

All the Best!

Regards,
Abdullah


#4

Thanks @AshwinS2 & @abdullahnj for your suggestions. I’ve tried many possible tricks and in my case selectors are static (already mentioned in original query). As I told you, sometimes it works and sometimes it enters data into an another field which has different selectors. I’m using set focus / click > type into.
And also, I’ve tried direct type into activity however, it’s getting failed.


#5

Hi @vikaskulhari

Use Element Exists activity to check the selector whether it is true or not

Thanks
Ashwin S


#6

Hi @AshwinS2, It’s still not working. even though, It’s returning true however, entering values in a wrong field. :frowning:

Anyways thanks for your support.

Best Regards,
Vikas


#7

Hi @vikaskulhari,

It’ll be really helpful if you could share a screenshot or two. Of the application you are working on, its selectors, etc. To help us better understand what you are facing.

Also, is the erroneous “typing” in the same field always or does that change too?

Regards,
Abdullah


#9

Hi @vikaskulhari
Did you find any solution for this?


#10

Dear @nenavana1, Nope… works sometimes only. are you facing the same issue?


#11

yes. I have done it like citrix it is working fine instead of java based


#12

@nenavana1, great job (y)

How did you fill data in a table of oracle form? I was facing an issue while filling up data in a table. Please let me know if you’ve done such solution.

Regards,
Vikas


#13

Not done:disappointed_relieved: