Working with iteration with oracle application

Hello Everyone,
I am new to the forum, Can anyone help me out to solve the below issue.
How to work with iteration (Excel for each row) in an oracle application. Since this application has multiple lines to be filled
The main challenge is I can execute single line but iteration is repeated in same line instead of next line item in oracle application.

I am assuming this has something to do with the selectors yourl are using for oracle application. Can you share the selector you use to enter information in?


Welcome to forums

For automation in Oracle application, you need to install java extension

So that UiPath can able to get the selectors of the fields

Then you are fine to place Typeinto activities, also the form and sample data to fill


Hi TimK,

Sharing you the oracle screen, where the bot perform execution and start again from the same line instead of next.

I have already installed the java extension and sucessfull process single line execution.
However my requirement is to fill multiple lines, where the type into active executes in same line instead of next line.
What should do so that the type into active jumps to the next line to fill the inputs. Attached oracle form for your reference.


Did you keep multiple Type Into and scrap that element?

Still it is giving error then you have to fix on the selector

Hope this helps


Hi Srinvas,
Thanks for your feeback,
I tried with mulitple line for type into activity, it still overrides in the same filed instead of next.

Does tabbing In the last cell take you to the next line?

If yes you can just populate data line by line by entering text and tabbing through fields.

If you can you please share the selectors of a field in row one and selector of field in row two.

hello @Syed_Faizaan,
instead of using selectors for typeinto just use “tab” sendhotkey to locate its position and then use typeinto(without selectors) to enter the data in it. It worked for me. Hope it works for u too