Extract structured data table + Fails to return values while running in Prod


I use the extract data table activity to get data from a webpage. It works fine when I run. But sometimes it fails to extract data. There is no error message. The activity runs fine but there is no data extracted. It throws off the bot in the next steps.

When I try to debug it gets the data.

Has any one faced this. How do we correct this?

Hi @Sairam_RPA ,

I see that you could retrieve data in debug mode but failing while running it, can you check if “WaitForReady” is complete.

With the available information, i cannot trace the exact issue but Try adding some delay ahead of extraction and see if it is working.

1 Like

I have delay for 30 seconds before it. I also have the activity under try catch.

I just added a condition to check ExtractDataTable.Rows.Count > 0 . and if that is condition is not met then I retry the extract Data Table activity. I will update as how it goes.

Did you face similar issue ?

Hi @Sairam_RPA ,

It seems strange. I can suggest if i have some more information about application, is it possible to share the application if it is open source. I can check and let you know.

30 seconds delay is not enough i guess. please increase the time out and also suggested by @Harika_Mudiam please select the wait for ready to complete to allow the page to complete before extracting the table.

and also one more question from my side is it un attended or attended automation.

i have faced similar issue before with un attended automation.

condition to check ExtractDataTable.Rows.Count > 0 and retry when the condition is not met solved the issue.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.