Extract Structured Data not working for multiple pages

datatable
activities
datascraping

#1

Hi,

I am trying to extract table data from multiple pages. When I run the bot, there’s nothing in the Extract Datatable. However, when I run the same sequence to extract data from a single page, it works fine.

Also, when I set the MaxNumberOfResults to a particular number, I am getting the expected results. But wantit to be flexible as I am not sure how many records I will get in the tables.

Here’s the ExtractMetadata : extract-table get_columns_name=‘1’ get_empty_columns=‘1’


#2

hlo roshan
i had made an attachment.test.xaml (14.7 KB)
challenge.xlsx (65.8 KB)


#3

Hi Pranesh,

Thank you for the reply.

I have used the same properties as you for Extract Structured Data activity. I have tried using your activity in my workflow but, still it didn’t work.


#4

If I specify the MaxNumberOfResults, it works. But, not when I set it to 0.


#5

Did you figure out a solution? I too faced the same issue!


#7

@pranesh your attached solution works! Solves the problem for now! Thanks!
But when i change the properties in my workflow exactly same as yours, even then it does not work! Not sure where it is going wrong. Have you come across this issue before? Done something to make it work?


#8

Interestingly i figured out, it is returning null in the extract table because it throws selectorNotFoundeException, as the next page link is not there on the last page! You ll get to see this if you change the continueOnError to false on the activity.


#9

Yeah. I noticed it. Unfortunately, I haven’t got the solution yet.


#10

use my flow


#11

Yes I did! Works only if I use yours, not even if I replicate something exactly the same as yours!
Thanks for the flow!


#12

Yeah, it didn’t work for me either. It works only if I run your workflow @pranesh


#13

This is not the issue. In @pranesh flow it issues error if you put on False ContinueOnError.
The problem is from the data declaration, not the scrape activity. If you initialize the DataTable with New System.Data.DataTable as default value, the flow will work correctly… I do not know what is the reason behind it, why it does not work without previous initialization.


#14

@c.ciprian - tried initializing the DataTable with New System.Data.DataTable, didn’t work


#15

Please attach your xaml here