Execute macro: Exception from HRESULT: 0x800A03EC

Hello Community,

I always get the error message, when I want to run my “execute macro” activity. It doesn’t matter if I try to run it on its own or within the whole automated process.

I already tried the solutions, which are suggested in other forum topics, but I haven’t found the correct solution yet.

I also checked, if there are other Excel activities in the background.

Do you have any suggestions?

image

Thank you,
Flo

Hi
Welcome to uipath community
Kindly update the excel.activities packages in the design tab-> manage packages -> project dependencies and update it
—restart your studio and try once

Make sure that execute macro is used within a excel application scope

Hope this would help you
Cheers @FloN

Hi @Palaniyappan,

Thank you for your warm welcome and for the very fast response.

Unfortunately, the problem isn’t solved.

Maybe, I should give more details about the macro.
It is used to fill in information in specific powerpoint slides from an excel file.

The macro was built before the new Powerpointslide activity was released.

1 Like

Hello @FloN
Close the excel before running the program and check whether its working or not ??

1 Like

Fine
Use a kill process activity before to this excel application scope where the macro is executed
— in the kill process mention the process name as “EXCEL” in property panel of kill process and try to execute the file
The reason might be that I t might be running in background

Cheers @FloN

@FloN
This is a macro error in excel. not the uipath logic error.
Pls check your macro

Hello guys,

first of all, thank you for your help and suggestions.
The problem was, that the links within the macro had to be updated.

As I didn’t build the macro by myself, I had to no idea where to look at.

Kind regards
Flo

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.