Excel Write Cell Issue

Greeting fellow roboteers!

I’m having an issue when using the Excel Application Scope (Set to not visible) and the Write Cell from within that scope.
For some reason, when I get to certain write cells (not all of them) the not visible property of the Application Scope seems to be superseded by something causing the Write Cell to be visible.

Has anyone come across this before and found a solution?

Thanks in advance,

1 Like

I wonder why its poping up because on disabling VISIBLE property in the excel application scope we wont see the excel opening in foreground…

Kindly remove the excel.package under project dependencies in the manage packages window in design tab of studio and reinstall the same package uipath.excel.activities and try once

and make sure that we have used only Excel activities and not Workbook activities
only these activities @JustAPo

Cheers @JustAPo


My first guess is that you are using excel application scope and using the Read\Write Range activities which are provisioned for the Workbook Range instead of the excel Range.

Please note that there are two different variations of the Read|Write range activities:-

  • For Excel Range (When MS Excel is installed).
  • For Workbook Range (When MS excel is not installed in your machine).

The above case generally happens when you use Workbook Read|Write activity inside the Excel application scope.

Please mark my answer as a solution if this helps.

Thanks and Regards,

Hi @hacky thanks for that, unfortunately it isn’t the issue. I’m using the Excel Range Write Cell activity.

Thank you non the less.

Were reinstalling excel packages in manage packages worked upon this
Cheers @JustAPo

Hi @Palaniyappan,
I’ve reinstalled, just waiting for some other jobs to finish running before I can check if it works. I shall get back to you :grinning:

Cheers @JustAPo

@Palaniyappan that doesn’t appear to have solved the issue :thinking:

Hmmm this is something strange
Upgrade excel package to your studio version and restart the studio And try once
Or can I have a view on the workflow a screenshot if possible
What kind of file is that .xlsx or .xls
Cheers @JustAPo

@Palaniyappan - I’m using a .xlsx file. I’ve got the section that is causing the issue below:

Also, here is the Excel package that is installed within the workflow:

Thanks for the help!