Excel is read-only

Hi,

Trying to edit a Excel that is protected by a password + Read only mode.


*password and workbook path are faked in the screenshot

When you open it normally, you could click to active the edit mode with the popup, but when using excel application scope, this message don’t show up so it’s force you to stay in read-only.

anyone have a solution for this?

Hi @MaxyArthes,

I’m afraid that the excel would be in read-only mode only if you’re are ticking the “Read-only” option, otherwise the excel is in edit mode

Best regards,
Marius

if I use the debug run option and stop at the excel application scope to see the Excel open, it’s writed “Read only” at the top. even tho the read-only option is not ticked. As the Excel itself is protected with the read only mode. so it is in read-only even if it not ticked =/

Hi @MaxyArthes,

Then untick the Visible option :slight_smile:
Anyway, you could try the read/write range workbook, without using the Excel Scope. It doesn’t even require to have the Excel installed

Best regards,
Marius

read/write out of Excel Scope worked, thanks!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.