Excel in RDS (Citrix), not local system

I am trying to open and edit an Excel sheet within a Windows RDS system. The problem is that I have access to the same file both on the local system and on the RDS, and I have to open it on the RDS or I won’t have access to the database to refresh the information in the Excel sheet.

I have tried with Attach Window, CV Screen Scope and with the Citrix recorder. I get neither of them to work, each time the Excel will open on my local system instead of within the RDS.

Is there a way around this?

Thanks in advance!

Make sure that the RDP SCREEN IS SET WITH full screen
Which can be done with MAXIMIZE WINDOW activity and keep this activity once after getting to the RDP screen
As you said you were able to access the same file in both the servers I hope that means the excel file is kept in a shared folder that can be accessed in either of the servers
If the rdp screen is set to full screen all the process been carried out will be made only inside that RDP Session

So use a excel application scope and pass the file path as input
That file path is the filepath of excel inside the rdp session so that we can open the excel inside the server

Or if we want to get the excel file on to the foreground of the RDP Screen then use Start process activity where pass The file path of excel as input which will bring the excel to foreground

Cheers @SJonsson

I have tried with setting to to full screen using both the Maximize window activity and the button for the remote service.
Yes, it is indeed a shared folder on the network that I am using and can be accessed on both servers.

The rest of the process is carried out inside the RDP, but as soon as I use Start Process for the Excel sheet it opens it on the local desktop, not within the Session. The same with the excel application scope.

The only way I have managed so far to open it is to use Window+R and enter the path name as input. Not the neatest way…

yah that would work for sure either
usually win+r command in cmd with the file path will open the file

Cheers @SJonsson

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.