Excel Formula adding @ at the beginning

Hello,

I’m trying to write this formula in excel Cell: “=IF(OR(V2<W2,W2=”“GA”"),V2,W2)"
When i do it manualy it works just fine, however when i use a write cell activity it adds @ at the beggining make it look like: “=@IF(OR(V2<W2,W2=”“GA”"),V2,W2)" and with this, it doesn’t work.

Any way to fix it and make sure it doesnt use @ ?

@fabio.r.mendes

Can you share screenshot of Write Cell activity along with expression you are passing here.

Here:

image

@fabio.r.mendes - This is a bug in studio…Please see here…

I am not sure whether it is fixed or not…

@loginerror - Could you please assist…

Unfortunately the fix is not done for Studio yet.
fyi @Raluca_Laic

Hello,

any prevision on when its going to be done ?

Cheers

Also, is there any work around, or any another way we can try to write the formula in excel ?

It’s working just fine for me…

image

image

Isn’t my process similar to yours?

yea,

Wierd… mine just adds the @ at the beginning

Is it actually making problems in your excel?

This is the documentation I found for the @:
image
image

It doesn’t affect, even it’s better as mentioned by excel.

The only problem is that this version is not supported by older versions of excel.

yea, i read that too.
But as soon as i remove the @ manually the formula works

Oh, okay… I thought the formula worked with @.

Which excel version do you have?

Office 365

I mean the actual version (Go To Account → About Excel)

image

Maybe if you update to the latest version, your issue could be solved.

ah sorry,

image

Seems like the same as yours

what’s your UiPath Studio version and the excel package version you’re using ?


Uipath version: 2021.4.4

yea, same as me

Is there any news on some workarounds for this problem? Maybe using older versions o Excel activities?

I faced this exact problem yesterday…
We found out that it doesn’t make a difference if we use write cell or write range activity.

We also found a workaround for us:

  • If we try to insert our excel formula in our local language e.g “=WENN(INDIREKT…”
    UiPath will add “@” to each function…
  • However, if we insert the formula in English eg. “=IF(…”
    Uipath doesn’t add “@” for us.

It seems as UIPath tries to parse the input before inserting it in Excel and there seems to be a bug… When inserting the English version it doesn’t parse the input and just copies it in.
Correct me if I am wrong?

Furthermore, we also faced problems with the Type Into activity in Excel.
It doesn’t work for us at all! It’s inserting strings not where it is supposed to.
The selector is fine!

We used the latest version.
Changing versions doesn’t affect the behavior.