Excel Application Scope causes robot stopped (code: 0xC0000005)

Hello,

I am facing a very strange situation.
I want to write a table (3600 rows, some cells with a large text) into an Excel file.
I’m using the Excel Application Scope with below settings:

image

When the activity is started I receive the below error and the robot is stopped:
RemoteException wrapping System.Exception: Job stopped with an unexpected exit code: 0xC0000005

I will write below what I already tried to fix this but nothing worked:

  1. Kill EXCEL process before
    2.Remove the columns that have large text

UiPath Studio: 2020.10.2
UiPath.Excel.Activities: v2.10.4

Thank you in advance for any new idea,
Vlad

Try Write Range from Workbook Activities, it’s more efficient than Excel Application Scope etc.

1 Like

I forgot to specify that I already tried with Write Range and I have another problem.
When I’m trying to open the resulted excel file, I receive the below error:

Further I need to know what sheets (the name of the sheets) I have in the excel file.
For this part I have to use the Excel App Scope to extract the workbook and further to extract all sheets to write only in some sheets.

When I try to read the sheets from excel, I receive the below error in UiPath Studio:
Failed opening the Excel file ABC.xlsx. Possible reasons: the file is corrupt, the file is already used by another process or you don’t have permissions to open the file.

Does someone or something else already have it open?

No.
I think that the only option is “the file is corrupt” but I don’t know what it means

Make sure the file isn’t set to read-only. (Right-click the file and look in Properties)

Does the file open in Excel?

My conclusion:

I have a total of 15 columns and 3 of them contain a large text inside.
That error is caused by large volume of data.
If I remove those 3 colums, everything is fine.

I didn’t find a solution to keep them and everything to be fine.