Excel and Mail packages issues

Hello world,

I have come across an issue with Excel and Mail Core packages.
I am using Studio 2018.2.3 version (forced to do so, so that it’s compatile with old orchestrator in production). Today, when I opened my project I got an error, that an activity in the workflow is not present in the installed activities of the studio:

The error appeared for activities inside Excel and Mail scope. I checked and they did not appear in the Activity panel. It strikes me as weird, because I always had it before and this is first time something like this happened. I opened the Manage Packages to see what was wrong and found out that Excel and Mail packages were actually installed. Reinstalling didn’t help, so I tried to Update to the version as per screenshots below:

I updated successfully (confirmed that Update button turned grey and updated version number was the current one), I reopened Studio after this, and Activities in the workflow appeared normally, however when I hit “Run” an error appeared saying that those Activities are still not available. I checked in the Acitivities panel by writing “excel…” “mail…” and they did not appear. When I checked Package version once again, old version numbers with available Update button were there once again. No matter how many times I do this, after reopening it gets back to the older version (which by the way, should work too, as it did for the whole time until today).

Anyone else having this problem? Any idea how this can be fixed and why the old versions are suddenly not working? Would appreciate some help, thanks

Hi @salladinne,

May I know did you used project dependencies in Manage package studio to install the activities.



Don’t really know how to check this, can you explain?


The Project Dependencies bookmark is only available in newer versions - in 2018.2.3 Manage Packages studio looks smth like this:

Problem solved- needed to uncheck “AutoUpdate” - newer package versions are not compatible with older studio version.