Excel Addin Installation Fails

Following UIPath Academy Training, doing Build Your First Automation example, and encountered two problems:

  1. The video doesn’t load (tried Chrome / Edge on Windows 10 and also Safari / Chrome on Mac) (UiPath Academy)
  2. More importantly I cannot install the excel add in using StudioX 2021.2.0-beta.44 Community successfully and get the following error:

Capture

I’ve also tried to manually install it by double clicking the VSTO to no avail.

I have Microsoft Excel for Microsoft 365 MSO 16.0.13801.20240

Any help would be appreciated.

Based on the error, I would suggest running the built in Office Repair Tool from the Tools tab and then try installing the extension again. Microsoft is working with us to identify and fix some bugs in their update installer than can leave Excel in a bad state. If the UiPath repair tool does not work, I would next try running Office’s repair from Add/Remove programs.

1 Like

Thanks Andrew - Office Repair Tool from Tools tab didn’t do it for me, but then I used Office’s Quick Repair and it’s working now - appreciate the quick help!

1 Like

I am having a similar issue:

I’ve attempted both the built-in Excel repair tool and the UiPath repair tool. The log for the Uipath repair tool generated this:

Checking interop registry entries…

Generating script for Excel Interop repair actions <<<

Error:
UiPath.Integration.OfficeExtensions.OfficeRepair.RepairActionException: Cannot find interop typelib registry entries. Please re-install Microsoft Excel.
at UiPath.Integration.OfficeExtensions.OfficeRepair.OfficeRepairActions.ExcelInteropRepair.RepairTypeLibRegistryEntries(IRepairActionExecutor actionExecutor)
at UiPath.Integration.OfficeExtensions.OfficeRepair.OfficeRepairActions.RepairOfficeInteropAction.ExecuteForExecutor(IRepairActionExecutor actionExecutor)
at UiPath.Integration.OfficeExtensions.OfficeRepair.OfficeRepairWindow.b__17_0(RepairOfficeInteropAction action)
at UiPath.Integration.OfficeExtensions.OfficeRepair.OfficeRepairWindow.TryExecuteAction(OfficeAppInfo officeAppInfo, Action`1 action, Boolean resetActionButtons)

Note: Excel is up to date.

Neither of those worked for me - but doing a quick repair of MS Office did the trick.

Maybe it will help you: