Error with Updated Library

I created a library, and published it.
The first version(1.01) worked fine, but when I made some changes to the library, published it(1.02), and tried to add it as a dependency, the following error popped up:

First, I created a simple library in my EmbeddedLinq workflow(Thats the name I’ve given).
Then I made changes to the exact same library and published it from there.
Any idea why this has happened?
Help would be most appreciated, Thanks in advance!

You have exactly what the error says. Check your dependencies as you have added the library as dependency.

Hi Alexander,
Thank you for your response, but I have already done that:

Also another issue I’d like to bring to your notice, I’ve added the input and output arguments I wish to feed into my library, but I am not able to see them. Here is a screenshot of the arguments:
And here is the screenshot of the library:

Thank you

  1. What version of studio are you using? I recommend you to try the 21.2 Preview.
  2. Why do you want to add Embedded.Linq library to the library itself? Don’t do this. Just edit the changes and publish the library.
  3. Make sure your arguments are required to show in UI (21.2 and higher) otherwise they will show only in Properties panel.
1 Like

Thank you @alexandru,

The arguments are showing up now, thanks to your guidance!
The issue with Library still persists, and I have a feeling that it has something to do with the version of UiPath I am using, which is 20.10.4.

Either that, or I am making some rookie mistake.

Thanks, once again!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.