Are you missing an assembly reference?

Dear All

After upgrading to 21.4, somehow my libraries have started displaying error message when clicking Publish. (Both to Local and Orchestrator)

Error Message : The type or namespace name ‘MyOwnLib’ does not exist in the namespace ‘MyOwnLib.MyOwnLib’ (are you missing an assembly reference?)

Even the library I had no issues 2 days ago shows the same error message even though I had no updates on that library at all.

Anyone having any pointers to resolve this…? thanks in advance!

1 Like

Im facing the same issue:
image

Again:
image
This time I kept the UiPath.System dependencie to the older version 20.10.

I just opened a ticket for that: 00920424

After some troubleshooting, the problem seen related to the “Invoke Workflow Activity” and only if this activity is invoking an workflow in a subfolder of the project.

But it’s only happening when using this activity in an older library, made in an older version of studio. I tried reproduce the same in a Blank Library and no error happened.

I make an diff between the xml of the old version of UiPath Studio workflow and the new one, and even copied and pasted, and the problem still occurs only on the old version. Cleaning the imports don`t worked as well…

Well, at least I managed to make it work somehow. I created a new library project, and imported all the workflows from the old one. It was enough to make it work again.

Update:
I guess its related to the name of the library, if it has “.” or “_” on the name, the error occurs when there’s a invoke workflow on the code.

2 Likes

Thanks a lot! This resolved issues!

1 Like

@loginerror FYI about this bug

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.