Error while using library

Hi all,

We are facing some issues with UiPath.UiAutomation packages version. First of all, the context of the platform:

  1. Studio v20.10.0.2
  2. Orchestrator v2020.4.1

The difference between version is due to a previous error with java applications and UiExplorer. This previous issue is supposed to be resolve with UiPath.UiAutomation v20.12-preview, the one who needs Studio 20.10 or higher.

We had one Exchange library developed with some extra functionalities, where we use the native activities of UiPath. The library has been working perfectly with previous versions of UiPath but now…

We have recently updated every dependencie to the new ones and the library stop working. You can use it as module, invoking workflow directly with “Invoke Workflow activity” but it doesn’t work when you publish it in orchestrator as library.

In this case, when you try to execute it, an error is raised: “Object reference not set an instant of an object” (Common error when you don’t fill the arguments of the activity or so). I’ve been trying to do a lot of things and finally i can resolve as follows:

  1. Remove UiPath.UiAutomation package from library
  2. Republish the library
  3. Remove UiPath.UiAutomation from Main

As you can supposed, it doesn’t seem an optimal solution (there will be libraries where this package is needed)… Do you ever face to similar issue? Is a known error at this moment? (I have found out nothing related)

Sorry for not attaching the code, but i can’t share it.

Thanks for every comment recieved in advance

Hi @Alvaro_RS

Does this happen with a fresh library project as well?

I also recall that some recent fixes to library projects require you to republish your library for them to take effect.

Thus, just to make sure that this was it -> if you add the UIAutomation package to both projects, does it maybe simply work now? (it would be nice to see first if the republish was the reason it was fixed, and not removing of the packages)

This happened with a library developed in previous version of UiPath. We just analyze the difference between project.json of both version and update it to the new format/content.

I tried to republish the library twice and the error was the same.

The orchestrator version i have (v2020.4.1) seems to have some problems with the compiler of Studio v2020.10.2 and i’m in progress to update the orchestrator version to v2020.4.3 (UiPath support has recommed me this version).

I’ll try again after update the orchestrator to check if the error with UiAutomation dependency included in the library persist or it solved.

In any case, thanks for the tip!

1 Like

Sure, let us know how it went.