Error using Insert activity within database workflow

Hi, everyone.
Can someone assist me I encounter problem on using insert activity to insert database into database. I tried using run command activity and run manual syntax command and it does not have any issue but when im using insert activity its come out with error as below. I try simplified my data to just one row just to test to push data successfully but it just does not work. Below is my sample of activity flow, excel data ,the error and my database. My database first column and last column is auto increment each time i push data in.

Would be a great help if anyone have any advice for me.
Thank You,
Best Regards,

Hi @Paankhand

I see that the Number of columns are different in your SQL DB and DataTable.
Can you please add all the columns in your DataTable and then try runnning the workflow.

Your Ops_Queue_monitoring_id is a primary key which is not even present in you dataTable.

Hi @adiijaiin,

Thank you for the advice but I have add all the columns in my Datatable matched my database but still I receive the same error as before.

@Paankhand Did you built connection in ODBC through Tns.ora?

Can you display the query and run the same directly into My SQL, see if you are able to execute that ?

I’m not sure Tns.ora but yes I built connection using ODBC.

I have try using Run Command activity using this syntax i attached below and UiPath able to execute it successfully into database.

@Paankhand was connection successful?