Execute Non query Database activity error

I’m trying to use Insert Database activity, though its keeping giving an error. Pls advise what’s missing. I have the Database connect in beginning which is working fine. I tried using Insert activity though keep getting same error.


error states the syntax error is causing issue.

Did you wrote the query? just jave a double check on the line mentioned in the error.

If possible, you can share the query too.

Always recommended, please run the query well in the studio or any platform to verify and then use it with variables in the workflow.

Yes, query is written in the second screen shot. You can see data elements and values that i’m trying to pass. The error doesn’t even make sense of integer & integer13.

you can see the Query worked when I run the SQL database studio

ok got it

The studio has the database selected and hence it is running the command.

In sql code from UiPath
i assume you passed the correct connection string so just try adding the entire database name from it root?

something like

iNSERT Into [MasterDBName].[dbo].[yourDatatabse] (…

You can get that hierarchy from the studio itself… just try once adding the full name

Correct here is the schema
image

Show us the query you have in the Execute Non Query activity. Something is wrong with the syntax. Don’t show us you running the query in SQL. Show what you have in the activity.

I already have it in the screen shot. look up the first blog. Never mind I figured out

You should post how you fixed it in case someone else runs into the same issue and finds your post looking for a solution.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.