Error in click activity in assignment 2


#1

Hello Guys, Im getting System.nullrefrence Exception in click In assignment 2 even i have given a default value in argument. Please help me out Guys.Process.xaml (15.3 KB)


#3

Use this selector in click Activity -

ClickSelector


#4

Hello @Suman7 I already used It you can check it in my workflow. Im getting this error.

{
“message”: "Click ‘A https://acme-test.ui…’: Cannot find the UI element corresponding to this selector: ",
“level”: “Error”,
“logType”: “Default”,
“timeStamp”: “15:37:26”,
“processVersion”: “1.0.0.0”,
“jobId”: “f59d103f-590d-4973-a5de-6dfb701e81db”,
“robotName”: “orch”,
“machineId”: 64281,
“fileName”: “Process”,
“logF_BusinessProcessName”: “Framework”
}Process.xaml (22.3 KB)


#5

Hi Jitendra,

This selector is working perfectly.
I want you to check 2 things -

  1. Resolution of browser (Its working perfectly with 80% resolution). You can see the same in the below screenshot.

  2. Whether the argument is initialized. I tried by giving default value in argument and its working for me.


#6

Yes when I’m giving default value its working perfectly but when I’m running the main workflow its not working. don’t know why. @Suman7 help me out, what is the issue? and when I runs main workflow it does the login and logout several times.


#7

Pls share your Main.xaml


#8

Main.xaml (52.1 KB). @Suman7 please find the Main workflow.


#9

Hi Jitendra,

Please follow the below 2 steps -

  1. Assign the dynamic selector to a temp variable (as test_Var in Screenshot)
  2. Pass the temp variable into the selector of Click activity.

Find the below screenshots.



#10

Thanks @Suman7


#11

thank you, this worked for me as well :partying_face:

However, it’s not working for the Process part of the workflow.
The execution is faulted


#12

Your’e welcome @jitendra_123

@Aziza101 : Let me know the issue you are facing.