Error: Could not find file


Please help! The robot types the file path correctly when saving the file and then it stops and this error appears : “On Element Appear ‘DirectUIHWND’: Could not find file 'C:\Users\mki\Desktop\UIpath-GenerateYearlyreport-PerformerProcess\Data\Temp\Report-RO657483-2019-January.csv”.

Thank you in advance.

Hy @Maryem_Karoui,

This error may seen a bit to obvious, but please check exact file path for the file, this error is very unusual.

Please let me know

Hey @Maryem_Karoui

Can you check this path, if it exists or not : C:\Users\mki\Desktop\UIpath-GenerateYearlyreport-PerformerProcess\Data\Temp

I didt! the robot writes the file path correctly but it saves the file in “Download” and that message error appears


Few things to check.

  1. Which browser are you using ?
  2. Is default download location download, If yes disable it.
    Go to settings, advance settings and disable Ask where to save each file before downloading to False
  3. Try downloading this file manually to this location.

IE and I tried to save it manually, then I run the robot, and it work (it saved it in the right file) but unfortunately the same error appeared again.


What purpose are you using on element appear ?

to close the downloading window, read CVS, merge data table and I put the Excel app scope in it as well

@Maryem_Karoui Make sure on element appear property
Repeat-Forever is set to FALSE

Yes it is

@Maryem_Karoui Okay, Give this a try, If you are trying to close the downloaing window, Use close window and not close application and see if it works.

Thank you

@Maryem_Karoui Does it solve your issue ?

No it didn’t work! I’m actually working on the “Generate Yearly Report Performance” I’m still trying to figure out the error.

I found where is the problem! its the file name! it dosn’t write the date and the month it write it 1 but not “January”
here’s the selectors of the year and the month

and here’s the path I wrote:

1 Like

Hy @Maryem_Karoui,

Sometimes the error is too obvious we cant see them lol.
Whenever an error like this happens the first thing you must do if the file is named the way you wanted and that you are calling it the same way.

Sometimes error messages confuse us, but not this time :slight_smile:

Please like my post and mark my answer as solution.

Thank you

1 Like

I solved it! It is too obvious! I had to delete “Type into” and create it again and it worked.
Thank you so much


Well done @Maryem_Karoui,

Glad I could help you!!


Hi! You can try Long Path Tool. It is very useful in such situations.