Enterprise not recognizing UiElement

I’m back again! It’s been a minute since I needed help from the forum.

Over the summer, I was an RPA intern and I developed a few projects for the company in UiPath Studio community edition. Near the end of my time there we worked to move my projects to enterprise edition since that is the version that the Virtual Machines use to run the bots.

I’ve accepted some remote work while I’m in school for the year and some issues have come up and we are trying to figure out why these issues are now present. We thought we took care of all migration related issues because it was functioning correctly when I left. I thought I knew what the issue was when my supervisor contacted me but I can’t even verify if I was right because a new issue came up.

In my automation, at the very beginning in fact, the robot opens up a browser and hits a few buttons in order to ensure the rest of the process will run smoothly (call it a preparation sequence). The issue now is that the robot is just stopping after it opens the browser. No buttons are pressed.

I tried to manually press the buttons to try and guide the robot through the preparation stage and get it back on its feet, but to no success.

I then checked to see if anything was wrong with the selectors, and to my surprise, UiPath wasn’t even recognizing buttons/dropdown menus as objects. There is no blue box that highlight the buttons I want the robot to interact with.

I know that in community this isn’t an issue because my supervisor has been using the automation I built for the past 3 weeks and it has worked successfully. He didn’t need to tweak it or have me look at it.

So in summary, UiPath Studio Enterprise isn’t recognizing certain buttons/dropdown menus that the robot needs to interact with as elements. I can’t reindicate them on screen because there isn’t any sign that the buttons are recognized as objects. If anyone could help me with some troubleshooting tips I would greatly appreciate it.

Oh and before I forget, all migration issues have been solved and Studio doesn’t say anything is wrong in any of the xaml files.

Thanks again!

Hi @Kriptiko,
Indeed it’s very strange issue but without any example of project and/or selector which is working on CE and not in EE it’s hard to say what can be the root cause of this problem. Please also remember that in case of EE issues you can always raise a ticket in our Technical Support.