Uipath activities are not working in another machine


My uipath path workflow is working fine in my local machine but not working properly when i tried to move the workflow in another machine in internet explorer.

Tried fixing the selectors but still no result.

Please help

@anussark what is the error messagea shown?

hi @anussark,
try to recheck your selector? Validation?

Could not find the UI element.The selectors are same in both the machines.
what should i do?

Usually “cannot find UI element” errors are thrown due to selector issue.Can you try highlighting the UI element which you are trying to identify?Also please check whether the application is synchronized with your developement

check if your selector has NO tags like idx, DIV… which are unstable. try using aaname, tag, rowname

Hi @anussark

Kindly have a look at below checklist, because i had same issue,

  1. check with selectors that includes app, win attributes. Check whether you have that application in the second system where you are trying to execute the workflow
  2. if you are using any browser, check whether they are similar like what you had in your local machine, like IE = IE, chrome = chrome, not here chrome, there IE. it wont work
  3. maximize the window using the maximize window screen sometimes elements may not be visible to be identified.
  4. change the dynamic values with wildcard symbol, even if you slight doubt over the selector and attribute values. —this is very important


when i am highlighting the elements it can hightlight but not able to click


enable simulate to click/type or send windowmessage property with click activity

Done that too still not working. My os is windows 10 and another machine has windows 7.
Is that a problem? Local IE is 11.13 and another is 11.0

nah nah nah…!
That’s not a issue…can you kindly tel me where it is getting stuck, like after getting to the browser, or inside the browser or its getting failed even to get into browser.

if its inside the browser, is it getting failed in first activity or fore-coming activities


it is failing inside the browser and after 3 click activities from the 4th one it is failing

If it is due to the selectors then howcome is the selector working in local


it implies very clearly that there is no issue with BROWSER…ok then lets start with first click thats getting failed. It would be very helpful if we can see the error or workflow. so that it would be very easy for us to debug the issue.



Please see the issue…I just have one doubt how the local machine selector is working then?

Hi @anussark,

id is always subjected to changes, please use some other stable attribute instead of “id” in your selector. or add wildcard to id alone and try please.
You are almost done, lets try this…


I did try with this…It did not work. so what should i do?

Any more suggestions guys?

Are you able to reselect the element on the other machine? That way you can get the properties that are selected there. Compare that with what you have on your local machine and if there is a difference between them try to use the wildcard there.

Yes i am able to do that.It got resolved once i reset the settings of IE to default then again the problem reappeared.Please help me out with this.