SAP Elements Identification Problem

selector
sap
studio

#1

Hi guys,

So, lately I came across this situation and I’m completely clueless why is it happening and how to deal with it.

Basically, i’m automating a process which interacts with SAP and Excel. Most of the time, it works fine and there is recognition of SAP table cells and other SAP elements.

But sometimes, out of nowhere, the robot simply stops identifying SAP elements, such as all table cells and some text fields and only recognizes top menu SAP buttons. If i try to identify again those elements, UiPath doesn’t recognise them anymore.

My UiPath Enterprise Studio version is: 2016.2.6274 and i’m using Windows 7 Enterprise (64bit).

Have any of you guys had a similar problem? I’d really appreciate some help here!

P.S: I’ve marked Activate Scripting in the Client SAP Configuration. In SAP Server, the sapgui\user_scripting parameter has the “Current Value” set to True.

Best regards.


#2

Sounds to me like the selector may be changing - have you tried using UiExplorer to test different version of the table loading?

Alternatively, click text works very well with SAP as does Full Text screen scraping if you cannot get it to work consistently with the scripting approach.


#3

That’s not it richard. The problem is that the elements just cant be identified.

Do you know what is the usual memory consumption from UiPath studio in processes task manager? Mine is at 500k at the moment.

best regards.


#4

Doesn’t sound too high - UiPath Studio is quite intensive. Fortunately it doesn’t need to be open once you’ve developed your processes.


#5

i am also facing the same problem with SAP logon 740 where element ID is not available. Selector has only parent node. how to handle this issue.


#6

Hello Lawan,

I did not understand the reason behind this problem but i found a fix for it. Your robot will have to close SAP Logon and open it again.

Good luck.


#7

Is there any setting to be enabled in server to get the ID accessible in client side.


#8

SAP got upgraded in our system when we started facing inconsistency issue. upgraded from Logon Pad 730 to 740.

if we close SAP clear temp files and test recording is fine. But after multiple testing element gets un recognized.
This is peculiar as it worked fine in Logon Pad 730


#9

Iawanyaram,

I faced the same issue and i was using SAP logon 740…So your upgrade willl not fix the issue. I dont know if this is a UiPath Issue or a SAP issue. Anyway, just put a try catch logic, if the robot does not recognize SAP field or SAP Table, you have to restart SAP Logon. That worked for me!

Good luck in that.

Best regards


#10

Dont forget to enable the current value and the desired value of sapgui\user_scripting in SAP Server side.


#11

Thanks. Can you tell when what specific catch exception to use to handle the field/element not recognized and how to restart SAP logon from UIStudio


#12

After the robot logs in SAP Logon, i just put a try catch with a click SAP element in a certain SAP transaction which i know it only works when UiPath is recognizing SAP elements. The catch block catches “Selector not found exception” and then i send a “ALT+F4” key to close the window and then another “ALT+F4” to close SAP Logon. Then i just call my normal workflow. When everything is ok, the robot continues the normal process.


#13

thanks it helps


#14

now we are facing issue inspite of deleting temp files also. we tried to restart the system after clearing temp files in SAP. Have raised helpdesk ticket.


#15

I’m facing the same issue.

Uipath is not able to detect object in SAP 740. It detects whole application as one sometimes.

Note: scripting is enabled at server & client side.


#16

@ricardoalqueidao @legendz At server restart the SAP scripting configuration on the server side may be lost. Could you check that?


#17

The scripting is absolutely fine. we run lot of GUI scripts using vbs.

The problem here is uipath is not identifying objects which vb script can do.


#18

Hello,

Here are some random thoughts on SAP issues:

  • when upgrading SAP it is possible for the selectors to change. If a selector fails when executing the workflow you’ll basically have to re-create it using the recorder or UiExplorer

  • I encountered a case when the scripting setting on the server was not persisted and it was reset to deafult false at server restart. Please check if that’s the case (probably isn’t).

  • when a selector fails try to use UiExplorer and see if you can select the SAP UI element on the screen.
    If not try to use the UI tree in the left and expand it to see if you can access any other SAP objects.
    The question is: is only one selector that is not working or nothing is working anymore on SAP.

  • as far as I understand you guys automate the logon into SAP. I’m not sure but I think I encountered a case when SAP GUI scripting was unavailable on login screen but after logging in everything else worked just fine.
    I would not use selectors when automating the logon to SAP. I probably go with keyboard automation and some regular selectors.
    Can you confirm that after logging in other selectors work or not?

  • UiPath uses SAP GUI scripting which is based on COM. As far as I understand it seems that at some point everything stops working. When this happens can you please try to use SAP GUI scripting from VBS to see if it still works?

  • If UiPath is not working at all on SAP you should collect ETL traces as explained here: https://www.uipath.com/guides/enabling-tracing and send it to us. Also we can schedule a remote support session if that’s OK with you.
    If not you can still automate SAP without SAP GUI scripting using click text, keyboard, images and regular selector as explained here: https://www.uipath.com/kb-articles/how-to-automate-sap-applications-the-quick-guide

  • Here is a script that performs basic checks on SAP GUI scripting: https://www.dropbox.com/s/m33xivejisu1oss/sap-check.js?dl=0
    The source code contains all the details about how to execute it as comments.
    You should run it when SAP automation works and also when it stopped working to see if there are differences in diagnostic messages in the console.

Adrian.


#19

My Problem got resolved after reinstalling UiPath Studio


#20

Having the same problem, I am doing a process in SAP and I have a selector and can not change several processes, it is lost as if in SAP the chain is changed to the Selector, the nose and the problem can be fixed but the help