Windows Server Issue

Hello, I’m having an issue with the UiPath UiAutomation everytime you try to go into select element mode, it throws this error:

MicrosoftTeams-image
The machine is Windows Server 2012 R2, it has desktop experience and .net framework installed.

We tried everything, reinstalling .net, and uipath and running as admin.

Is there anything missing from my side? or is there a problems with the permissions given to me in that machine?

Which version of studio,robot,orchestrator are you running?
Which .NET version did you install?
Did you update all the activities already in your project?

Uipath: lastest avalaible stable version in the platform.uipath.com (I think v2019.10.4)
.Net version: Tried both the oldest required as seen here: https://docs.uipath.com/robot/docs/software-requirements and the newest 4.8.
Activities packages: tried reinstalling all of them and installing and tried different versions and nothing.

Desktop experience was installed. and all of the features needed in Windows Server.

A bit late reponse on my end. Did you solve this problem already @AlexJA ?
Did you have any other software installed on which you use the select element (or are you just using browsers).
The only thing i could find which would come close is, that the installation did not go as supposed to. Im running several Server 2012 installations, but i cannot reproduce this problem. Do you see anything in eventviewer on this problem?