Element Exists freezes on app crash

uiautomation
activities
core_activities

#1

I am using Element Exists activity to make my bot decide which path to take through if activity.
But the problem is that during this process the application on which the bot is working crashes. At this point of time the element exist activity does not do anything.
It does not return any value(either true or false) and also it doesn’t crash(so that i can catch the exception).
What should i do?
TimeoutMS = 3000
Waitforready = Complete


#2

@Aditya123 what the error says?


#3

or maybe try Find element activity to see if he finds it


#4

@nemtutruben UIPath is not throwing any error. It is also not giving any boolean value as output.
It just gets stuck there.


#5

Hi @Aditya123,

share your xaml file or send screenshot of the activity, so i can give the correct solution.

verify did you gave the output variable.

Regards,
Arivu


#6

Hi @arivu96,
I cannot share my xaml file.
The problem is that it is stuck at the element exist activity. It is not giving any output(I have specified an output variable), it is also not giving any error.
Is there any way to throw a error there or skip that activity when it has been on it for more than 20 seconds(or any other time period).


#7

Can you please share the screenshot to analyse?

And can you please check the variable type and whether value is getting assigned to the variable or not?


#9

@Aditya123 maybe the bot is waiting until the element appear, but the element didn’t appeared and because of that you didn’t have errors.


#10

@nemtutruben
Yeah that’s exactly what is happening. But I have kept the TimeOutMS equal to 3000. It should stop searching for the element after that.
What should I do to make the bot go forward in such a case. Ir at least make it throw an error.


#11

Could you try with WaitForReady Interactive? Or None?
If it works it would indicate an issue with waiting for application to respond blocking timeout.

Second thing - could you try with ElementExist outside any attach scope (change selector to accomodate if needed). With different WaitForReady settings if needed.
If it works it would indicate an issue with Attach when application crashes.

Either way it seems you found a bug that causes full freeze.
What’s your Studio version?
How the process is started (Studio, Orchestrator?)?


#12

Try on Element Appear activity. This might solve your problem . let us know once you check this


#13

Hi @andrzej.kniola,
Thanks for reply.

I tried the WaitForReady as Complete, Interactive and None. But they didn’t work.
I also tried it using outside the attach block. But the problem is still there.

Studio version : - 2016.2.6379
The process is started through the studio.


#14

Hi @karthick,
Thanx for reply,

I tried the on Element Appear activity. It is also freezing like element exists.
I checked the WaitActive and WaitVisible checkbox.
and I also set the Repeat Forever as False.

Please tell me if I am using this activity wrong.


#15

@Aditya123 maybe your program doesn’t open correctly. From what I’ve seen in your print screen Workshare has stopped working, maybe you are doing something when you open the program and then it crash.
The Robot wont find the element if there is no element. Try to open correctly your program. Split your code in multiple sequences and then try and see what part won’t work.


#16

@nemtutruben ,
the program works fine. i have tested the process 30 times and this occurs once or twice.
An application crashing is fine, I can handle that exception as long as the activity throws an error.
But the element exists activity just freezes.
The element that I am trying to find does not appear in the scenario of a crash, so logically it should return ‘False’ as output but it doesn’t return anything.
I have segregated my workflow in different sequences. Thats how I found out that the problem is in this particular activity. But i cant understand the reason behind this problem or the solution to it


#17

Looking through 2016.2 release notes upwards from your version, this doesn’t seem to be mentioned.

@qateam - any advice?


#18

We can investigate further