EDGE still running in the background when killing process

Hi,
I am running a bot involving REFramework, windows 10 and EDGE. On the KillingAllProcesses.xaml in REFramework it uses the ‘Kill Process’ activity and with the property ProcessName = ‘MicrosoftEdge’ it kills all instances of EDGE.
The problem is that EDGE keeps running in the background and the next time that an instance of EDGE is instantiated, it opens all the tabs that were previously opened.
I have googled for a while and there are a couple of windows policies ‘Allow Microsoft Edge to pre-launch at windows startup…’ and ‘Allow Microsoft Edge to start and load and New Tab Page…’) that can be enabled in the Local Group Policy Editor to prevent old tabs to reopen after killing the EDGE process or these policies can be directly modified in the windows registry but none of them seems to work.
Right now I am implementing a workaround that consist in after killing the process I reopen EDGE and then my bot closes each tab, one after one but I wonder if there is a better and more optimal way of using the Kill Process activity with EDGE.

Thanks,
Sergio.

Hello @sergio.lopezjimeno!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly
Forum_Staff

Hi @sergio.lopezjimeno

Welcome to our UiPath Forum! :slight_smile:

Isn’t it just a setting in Edge settings? Each browser let’s you control that from its settings.

Hi,

It used to be but at least from versions previous to windows build 1909. Now it is not anymore. You can’t find that option in EDGE >> Settings >> System as it used to be. As I said, there are new options in the Local Group Policy editor but those are not preventing to open the old tabs when uipath studio opens an EDGE instance after having killed all EDGE processes.

Strange!

For me, also 1909, it is still here (just greyed out due to company policies):
image

Hi Maciej,

Sorry for the confusion. As you have said, the System option is still there in Settings in EDGE. What I meant is that Microsoft has removed some of the settings that there were in previous versions there like “Continue running background apps when Microsoft Edge is closed”.

image

Use “msedge” in process name it will work

2 Likes

@rohanjs94 It worked. Thanks man…! :slight_smile:

thanks, that worked!