Does anyone know why my get email timesout?

Hey everyone during my go live my first step is Get Outlook mail message. As it does read the email but does not move further. Would any happen to know why I keep getting this error?


maybe there are a lot of emails there? did you try setting TOP 1 or something to see if it goes?

I have it as top 30 with the email coming in first. The email is the first email. It worked on my computer and worked on another clients computer I went live with.

What does the detail logging say?


Is Outlook application opened at the time of running process or not ?

Operation has timed out is in the output

Yes the application is open it is able to ready the mail and mark it as unread and then fails. I put a message box after but fails before the message box.

any attachments in the email?
Also, how do you know it is reading the email?
What is the next step after reading the email?
Have you tried with Exchange server?


You are getting error at Get Outlook Mail Message activity and then how you know it’s reading mails properly ?

So the email I’m trying to read is being marked unread in outlook letting me know it has acknowledged the email. But after that I get the error that pops up. I want to think if it is a package update issue. But my next activity is a message box then for each with a save mail message.

@seanp92 - the first email you are trying to read - does the error occur on any first email, or just this particular one email which is on the top.

What if you (temporarily) move that email to another folder? Does the bot run error free then?

Found out the solution. The mail package settings had to be updated.