Dependencies issues

Program encounters this error after I ran the uipath program after a month. It was OK before that. My version is Studio 2022.4.0 Community License.

The assembly compilation returned the following errors:

  • The type name ‘Activities’ does not exist in the type ‘System’
  • The type name ‘Collections’ does not exist in the type ‘System’
  • The type name ‘Type’ does not exist in the type ‘System’

I do have the dependency, UiPath.System.Activities

Appreciate your help. Thanks

Hello @NYK888

Did you tried to update the dependency packages? If not please update it and try to execute.

I had tried updated my dependency System.Activities to the latest version. But the errors are still there.

Can I check which dependency should I install to remove the errors? Thanks.

Hi @NYK888,

Could you please post a screenshot that shows us the Project Panel, workflow where some activities are placed and the Output Panel. This will help us, help you better.


As attached. Thanks


Check this settings of Packages . You have select the local check box.
Find the Screernshots.

1 Like

Dear Vaibhav,

Do you mean I need to uncheck the Local checkbox? Can I have the steps on how to resolve this?

Appreciate your help and response asap. Thanks

You have to check the local …check the location of the .nuget package in your system


Did you tried moving the project to an another folder and reopen from that location?

Also if you create a new project in studio are you facing this issue?

I have copy the folder to another location and run it. It is still the same.

If I create a new project in UIPath studio, what are the folders and files I copy to the new project??

I have an earlier version that I backup to another directory. That version is working, but good for me to know what happened here and try to solve the issue. Thanks.

My Nuget location is the same as yours.

Wonder what else is not correct? Thanks.

By mistake did you made any modification to the project.json file? Can you try deleting that file once and reopen the project.

I have delete the json file and reopen the project. It said document is invalid.

If I move to another location and run the application, it has the same error.

Can I check if I create a new project, what files from old project folder I need to copy over so that the project can be run without error? Thanks.

@NYK888 can you copy only the main.xaml and check whether its opening without any error or not.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.