Delay starting process

Hi All,
UiStodio wait about 30sec to 1min after clicking the run button. Does anyone know what can I do to decrease the wait time?
I opened up the port 443 from the firewall already.

Hello ,
Have you inserted any delay activity priorly?
Or Have you set any delay in your starting activities.
Kindly check.
Thank you

Thank you for the responds.
Nope, this happens even when I only have one write line activity.

Have you checked to see that it’s a delay in sending a signal from Orchestrator and receiving it by the Robot? Or is the delay after the Robot has received the instructions and you’re waiting for it to start or perform an activity within the process?

The first thing that comes to mind is to ensure that

  • Any unused dependencies are removed from the published package.
  • Any Exception Screenshots, and other unneeded files are not published with the project

Both of these would increase the compiled NuGet package and increase the transfer time. By default Orchestrator / IIS limits the publishing/upload size limit to 30MB.

I have not noticed any major delay like that when a job is initiated from Orchestrator in AWS to a Robot on AWS or external to AWS. Maybe scour your local robot logs to see if any errors are occurring.

Hi twhitehead,
In my case, I did not use Orchestrator. The delay happens every time I start/test the process with Studio or start from uiRobot. A simple write line will have me wait 30 sec before it will start.
All log will start after 30 sec.

Start process ( I press start)
wait for 30 sec or so (no output from studio)
After which log start to appear:
“XXXX execution started”
“write line”
“XXXX execution ended in: 00:00:01”

Thank you,

Could try enabling the low level tracing on your robot, may be it will highlight something useful to troubleshoot.

C:\>"C:\Program Files (x86)\UiPath\Studio\UiRobot.exe" /?
UiRobot <parameters>
Enable/Disable low level tracing:
  --enableLowLevel | --disableLowLevel
        --enableLowLevel    Enable low level tracing
        --disableLowLevel   Disable low level tracing