Delay in running the automation process

Ui studio process takes around 30 seconds to start after click Run button (even for just message box display). What could cause this delay start? Thanks

If you don’t have enough RAM on your machine, it could be delayed. 8GB is probably enough unless you have many things open. For high-density, need atleast 16GB though with only Studio installed.

I don’t know if that will answer your question though. Also, make sure you have an updated Studio version.

Thanks. I have 8GB Ram, processor: amd pro a10 8730b r5 and have the latest Studio installed. Not have many applications installed in my PC as well.

You could read this, but I don’t know if there was ever a solution:

Maybe it’s an installation issue? I remember I did have the issue come up in the past, but I haven’t seen this happen in a while.

check your .net installation libraries, clean up registry, temp and don’t have multiple apps open

I have faced such latency in the past and I tried all possible alternatives but no Joy.

Solution which worked for me :slight_smile:

  • back up all your Project files and folders.
  • have a fresh installation of Win 7 OS on your machine.
  • reinstall UiPath Studio properly.
  • Run it again and it will work fine.

Till the date, since then, I have never experienced any issues with UiPath.

Try this ! Hope it helps.

Let me know if you have other queries


thank you!! I will try this