Running Process on Studio takes 30+ Minutes to get started


I have a Process that I run on UiPath Studio. Ever since my company upgraded to the new version of UiPath Studio & Orchestrator, it takes more than thirty minutes for the process to start after Clicking on “Run File”. Any ideas how to solve this issue?

The last visible log on the output console in Studio panel is:

“Writing cache file to disc. Path: …\pathtocodefolder...local\nuget.cache”

I don’t know if this is related.

What I have already tried:

  • Restarting UiPath
  • Restarting Computer
  • Clearing .cache Folder
  • Check the UiPath.Settings file

Thanks in advance for any ideas.

Try running the project on a different machine. If the results are the same, you might have to look for optimization within your project, but if they’re not, then likely your machine needs to be upgraded.

My second approach to the solution is to comment out later sections in your code, and let the first few activities run to check if the project starts any faster.

1 Like

Thanks for your reply. The project is indeed very optimizable and a huuuge process with hundreds of workflows. Is your guess then that the delay is caused by the size of the project?

I tried running it on a different machine and it takes a long time as well.

hi @chusikowski

It might be taking this long to validate the project, try turning off the workflow analyzer and then check.

1 Like

Hi @chusikowski

If you’re experiencing significant delays when starting a process in UiPath Studio after upgrading and the last visible log message is related to writing a cache file, it could be related to various factors.

Make sure that your project’s package dependencies are up-to-date and compatible with the new version of UiPath Studio. Outdated or incompatible packages can sometimes cause delays.

1 Like

Hi @adiijaiin thanks a lot for your reply! Good idea but it’s not due to this because I am running it on an unattended license where the workflow analyzer is deactivated.

Is it a Windows project, I have observed the same behaviour sometimes in them.

1 Like

It is a Windows-Legacy project indeed.

Could you share the project’s outline. Like so.
Likely the first few activities you are running are doing a lot of background work and may cause it too take long to start.


1 Like

I actually tried disabling the whole process and running it. It still wouldn’t start for a long time.

Why could this be happening?

This is what the task manager looks like during after I run the file and nothing happens.

Ok, I cant see nothing out of the ordinary. Have you tried restarting your PC and starting the project as the only thing your PC does?

also send a SC of your project outline. Like so.

It could be that you need to split your process into different units.

1 Like

This is the project outline:

ok, 2 things.

  • Does gfb.exe take a long time to startup if you open it yourself?
  • I would recommend, commenting out activities, bottom, up. to check when the project boot time becomes acceptable.

Commenting everything out within the while loop, should optimize the project’s startup time, and then keep uncommenting to see what is taking the most time.

1 Like
  • No. gfb.exe is already open prior to starting the process
  • The project boot time seems to be unrelated with the amount of activities uncommented.

What I have realized though is that this problem is more noticeable on busy hours of the day. I.e from 10am - 4pm. From 4pm onwards, the process starts quickly after executing it.

Any idea what could be causing this?

Could you give some more explanation with what you mean by busy hours? Do you mean the network usage is higher thus affecting the project?

Are you using windows or windows legacy mode?

Also check if you have any redundant packages that you are not using, those could likely be the cause.