What's UiPath doing before starting UiPath Robot when I run the workflow from Studio?


#1

Hi,
On my personal laptop UiPath works fine and I’m really satisfied with it.

However, on my company PC (desktop PC), it takes about 60 seconds to start UiPath Robot when I run workflow from UiPath Studio screen.
Once start running. it works a bit slowly on the company PC but not so much, by the way.

I think one of the reasons is machine spec, but I don’t have any idea what’s the UiPath doing while trying to start running so I don’t know what to do so that I can improve it.

Does anyone have any ideas?


#2

Hi

I am not sure but as briefed by you, it does seems to be an issue of system specifications.
Can you please list down the specs for your home system.

Regards

Rajat


#3

Thanks for your reply, here’s what I know;

(company PC : which takes time to start Robot)
OS : Microsoft Windows 7 Enterprise
OS version: 6.1.7601 Service Pack 1 build 7601
system type: x86-based PC
processor: x64 Family 6 Model 42 Stepping 7 GenuineIntel ~3101 Mhz
physical memory: 3,242 MB (available: 1,863 MB)
virtual memory : 6,482 MB (5,079 MB)

(my own PC: on which Robot launches quickly)
OS : Microsoft Windows 7 Professional
OS version: 6.1.7601 Service Pack 1 build 7601
system type: x64-based PC
processor: Intel64 Family 6 Model 78 Stepping 3 GenuineIntel ~984 Mhz
physical memory: 8,081 MB (available: 3,634 MB)
virtual memory : 16,161 MB (11,591 MB)


#4

Usually, I have noticed… Whenever we do any changes in workflow then it takes time… but if we run same workflow without any updates then it runs quickly.


#5

Hi

As you can see the minimum requirement is 4 GB RAM while your home system has ~3 GB of RAM, hence it will take time to load.

Regards

Rajat


#6

Thank you both, I got your points :slight_smile:
I’ll consult our staff to upgrade my machine spec anyway!


#7

RAM upgrade definitely won’t hurt, especially since it’s cheap to do for desktops.

What I’m wondering though… do your work firewalls allow access to UiPath licensing servers (related - did you need to do manual activation or did the default procedure work)?
I’ve seen situations where a FW would be set to just drop the packets, hence the software will wait for the full timeout before doing anything (from what I can tell starting a robot does also start license validation routine).


#8

Thanks for the info!

Actually our company FW does prevent access to the licensing server, but it seems not so big problem because Robot on my own laptop launches quickly even behind the same proxy (We have BYOD policy and I tried, but it might have been slower than on another network. I’ll try it next week!)


#9

I found a company desktop which has 4GB memory and tried running robot, and it took about 30 seconds to launch UiPath Robot…
I checked resources and pysical memory was still available at that time.
I also asked other member who has 4GB memory personal PC to run Robot and it starts in a few seconds.

Now I guess our antivirus software or security-related setting on the company PCs may harm UiPath’s performance.
I’ll do further investigation.


#10

Can we run uipath or the automation on pc start means without opening uipath software and then click on run?


#11

Hi Aditya,

Yes you can if you use Unattended Robots and Start/Schedule a job from Orchestrator.


#12

Can you tell me in brief?


#13

@a-taniya, has this issue been solved for you. We have the same issue here, running a work flow from studio takes 20-30 seconds to start. The system I am working on has 8GB so that cannot be the problem.
The event viewer has no mentions of UiPath.


#14

We did solve it yesterday by replacing our studio pc into another network segment. We have two, the old one starting with 10.10 and a new one starting with 10.60.
The studio pc was in the old segment. When we moved it to the new segment starting a workflow reacted without delay. Our network people told me the 10.10 segment uses other firewalls.