Date problem in filename

I am training at the Academy on creating the first automation in StudioX and as a result of the automation I received a document with the following name: YYYYMMDDReport.xlsx. That is, instead of the date, the name simply contains the date format. I have checked everything many times, but I cannot understand the reason for this. How to fix it?

Hi @Knowledge_Collector
Welcome to the UiPath Community! (Also, cool username :slight_smile: )

There is already a topic that discusses the same (or similar) problem with year. Try some of the solutions discussed here:

If you’re new to StudioX, it’s possible that you have used the literal string "YYYYMMDDReport.xlsx" (with the quotes, not without).

If this topic doesn’t solve your problem, I suggest you post a few screenshots or describe the issue with some details.
Please refer to the Forum FAQs about posting new topics :slight_smile:

Hi Ash!
Thanks for the help. I apologize for not being able to find an already created theme. I tried the solution from the topic you mentioned, but I only realized that the problem seems to be a mismatch in the date format of my system. Since I am from Russia and we have a different date format, this causes a problem. I haven’t figured out how to fix this. Perhaps I will create a new topic in “Ask in Your Language” in Russian. It is possible that in this way this particular problem can be solved more effectively.

To the best of my knowledge, I don’t think your locale should interfere with a specified dateformat such as YYYYMMDD. No matter what the locale, if you specify the dateformat, the date should be returned in the prescribed format.

Can you please post a screenshot of the activity where and how you’re using the dateformat?