Datascraping not returning full datatable


I have an issue with scraping data from a web page. I tried to scrape the data from the website as indicated in the screenshot below, I am interested in the pink data bits (hidden because it contains confidential information). However, using the data scraping tool it returns the data table as also indicate in the screenshot below the first screenshot. This data does not contain the pink information bits, it only returns the field names. I have tried changing the data definition to include get_columns_values, however this does not work. Does one of you have any suggesions on how to extract the data?

Anyone that could help me answer my question? I tried looking at other posts that might answer my question but haven’t been able to find one.

Hi @Merel,

The data you are trying to Scrape doesn’t seem to be structured. So you should try Get Text, Get Full Text and Get OCR text here.

Use UiExplorer to find a stable selector, if you dont see any stable selector use Anchor base activity.


The main problem is, that your data you want to scrape is in several input-fields. The table-scraping-tool only recognizes plain text.

If you want to read the value of an input-field you should use getText.
But you have to do this for every input-field you have.

Thanks Markus and Prankurjoshi. I didn’t realize that the table-scraping-tool only recognizes plain text. I ended up using the screen scraping tool, this allowed me to capture all the data and even underlying IE tabs, although not returning the data as structured as I’d like it did allow me to put all the IE information into Excel.

1 Like