Data table error: Filter Data Table: the value for argument 'Column Name' is not set or is invalid

Hi, I’m trying to filter the data table (DT_PaymentHistory) using “Filter data table” activity.

And I’m getting the error - Filter Data Table: the value for argument ‘Column Name’ is not set or is invalid.

In debug mode, I checked that the above data table does have a column which I’m trying to filter (Please see the image below)

Yet, still it says the given names for filtering the table is not there in the table?

Any help? Thanks!

1 Like

@manojj.yadav

Copy the Column name to the Filter datatable if any extra space given also it will raise an error

Hello @manojj.yadav

  1. Check Column Name: Make sure the column name you’re using for filtering exactly matches the column name in your DataTable. It’s case-sensitive.
  2. Verify DataTable: Confirm you’re using the correct DataTable variable (DT_PaymentHistory in your case) as input for the activity.
  3. Inspect in Debug Mode: While debugging, check the DataTable in the “Locals” panel to ensure column names match.
  4. Use String for Column Name: Provide the column name as a string in the “Column Name” property of the activity, e.g., "Date" or "PaymentStatus".

Thanks & Cheers!!!

1 Like

I checked all the things mentioned above and everything is right, yet it threw the same error again.

I changed the column name with
DT_Paymenthistory.Columns(3).ColumnName = “From_Date”
DT_Paymenthistory.Columns(4).ColumnName = “To_Date”

and then filtered the table with new assigned names. Now there’s no error.

1 Like

Hi @manojj.yadav

once can check the value which you passed in the filter datatable

thanks

1 Like

You have “From Date” and “To Date” in your Filter, but the above says it should be “From_Date” and “To_Date”

You left the _ out of your Filter definition.

1 Like

There was no “_” before, for some reason the filter activity couldn’t identify the column name (I literally copy pasted it 5 times). Hence, I reassigned the value with underscore and edited the filter activity with the edited name. Now everything’s working fine.

There is a slight chance that the whitespace between From and Date might have been a different character. Unfortunately based on which character sets are used this cán differ, though it’s an assumption that it can happen in these UiPath activities as you’ve had.

I’ve seen it happen mostly when things are copied from browsers or word documents.

Maybe too far fetched, but not impossible. THe fact that you solved it by replacing it with underscores does support it though.

1 Like

Hi @manojj.yadav ,
You can use column index, in data table index from 0
regards,
LNV

1 Like