Custom Activity is not visible in Manage Packages - Custom Activity Creator


I have built one custom activity and published as nuget file. But I cannot able to find it in the manage packages section. Through forum I saw some points to migrate the .net version and also noticed it will cause some reference issues which will lead to bigger problems.

Could any one help me in steps of proper migrating/fixing my problem. Thanks in advance.


Have a view on this doc for steps

But I also wonder whether u also have similar issue like this

If it’s on compatibility issue try with this

Cheers @ManiPrajwal_K

Its compatibility issue only that I understood. Because it was working fine in my community version of Studio. It is not working on legacy workflows.

Migration document I have alreay read and unfortunately, I cannot understand it completely. Could you help in making me understand the below steps:

  1. Copy references and clear everything from the .csproj file.
  2. Manually update the .csproj file to the new format.
  3. Add the target framework net6.0-windows.
  4. Mark the original references as net461 only by adding a condition.
  5. Add a new reference section with conditions for net6.0-windows. You must declare the following WWF dependencies for .NET: UiPath.Workflow.Runtime, UiPath.Workflow, System.Activities.Core.Presentation, System.Activities.Metadata. Make sure all your dependencies support .NET. You might need to find newer package versions or replacement packages.

Thanks @Palaniyappan

@StefanSchnell @YAZIDI @loginerror @Tudor_Sandu – I noticed you have provided some solutions earlier. Could you please help for my issue as well.

I’m working on building a custom activity for my windows-legacy workflows. As mentioned in my main question, I’m unable to find my nuget file from UiPath Studio. I have tried installing UiPath Activity Creator v3 and redid all my work again and published from VS 2022 - Professional v17.3.7.

I thought of trying out with VS 2019, I could not manage to install activity creator extension :smiling_face_with_tear:

Thanks in Advance!!

Hi @ManiPrajwal_K

Can you try this-

  1. Ensure that the NuGet package source where you published your custom activity is properly configured in UiPath Studio. To do this, go to “Settings” in UiPath Studio, navigate to “Package Sources,” and make sure your custom source is listed and enabled.
  2. Verify that the package name and version in your NuGet package match what you are searching for in UiPath Studio. Sometimes, typos or version mismatches can cause the package not to appear.
  3. In the “Manage Packages” window in UiPath Studio, click the “Settings” icon (a gear) and select “Clear All Filters.” This will force a refresh of the package list.


Hi Nitya!! Thank you and I have already tried all the suggested steps!! But no luck!

1 Like

HI @ManiPrajwal_K

  • Ensure that the version of your custom activity package is compatible with the version of UiPath you are using.
  • Sometimes, upgrading UiPath can resolve compatibility issues.
  • Verify that the NuGet package for your custom activity is stored in a location that UiPath can access. If it’s on a network drive, ensure that UiPath has the necessary permissions to access it.

Hi Vinitha, I understood that mine was a compatibility issue. I’m uisng windows-legacy workflows in the Studio, hence I cannot able to use my Custom activity. So I need help in fixing this issue as mentioned earlier!

Okay @ManiPrajwal_K

can you Please try this steps once

  • Open UiPath Studio - Go to the Manage Packages section
  • In the Manage Packages window, click the Settings icon - Make sure the correct package source is selected in the Package Sources tab.
  • Verify that the NuGet feed where you published your custom activity is added and enabled.
  • If it’s not, add it by clicking the “+” button and providing the NuGet feed URL or local package path.
  • In the Manage Packages window - try clicking the “Refresh” button. This will refresh the list of available packages from the selected package source.
  • Verify that the NuGet package you created contains the necessary metadata, including package ID, version, and description. This information is used by UiPath to identify and display packages correctly.

If you continue to face issues with Windows Legacy workflows, consider migrating to modern workflows (ReFramework or Flowchart-based). UiPath is increasingly focusing on modern workflows, and they may offer a smoother experience for managing custom activities and packages.