Could not load file or assembly '{ProjectName}, Culture=neutral, PublicKeyToken=null'. The system cannot find the file specified

Hi all,
I have deployed the package in orchestrator using azure devops pipeline.
When running the process from orchestrator i am getting the follwing error.

Can someone knows how to fix it.

Thank you


Looks like the target machine is not able to find the package or download the package…for now can you try to copy the package from dev machine to the target machine and check if that sovles



I am deploying fro azure, so i donot want to manually copy it


The issue is not with deploying with azure I believe…the issue is in the target system…may be it is unable to identify or connect to the orchestrator feed to download the required package…please check the firewalls if something is blocking



I have manually published from studio, it is working fine. but when published from azure only, it is facing issue. I have checked the firewalls, there are no blockers.

Hi @Anil_G @nagaabhishekreddy.c ,
If you are working with Windows compatible project then it might be related to default CLI version.
the default CLI version that comes with it is 21.10 and it’s not able to capable to build Windows compatible project which are build on .net core. hence processes published via default CLI throws such error.

Please upgrade your devops plugin to 3.0 which allows you to choose and download a different version of the CLI, by using the UiPath InstallPlatform task( This offers the possibility to pack Windows and Cross-platform projects.


1 Like

It is working fine with the above process. But when publishing the package to subfolders, the name of the process is appending with main.xaml. Actual package name in project.json: ABCD, package name after publishing: ABCD_Main.xaml.
Is there an activity in azure devops to fix the package name?

Which Studio version did you use? We are using Studio v22.10.3 and tried publishing a new version of the project from Studio to Orchestrator and ran into the same error message.

I have posted the answer in this Update of Libraries and Processes from Legacy to Windows - Build Pipeline - #24 by nagaabhishekreddy.c