Update of Libraries and Processes from Legacy to Windows - Build Pipeline

We updated Libraries and processes from Legacy to Windows compatibility. Since this update the deployments which we make with the UiPath Azure DevOps extension are broken. When we deploy a new version of a library with the deployment pipeline and include it into a process, then there are no activates shown from this library. And when we deploy a new version of a process, we get this error when we start the process.
Error in the Orchestrator:
Could not load file or assembly ‘, Culture=neutral, PublicKeyToken=null’. The system cannot find the file specified
Currently the only way to deploy the libraries and processes is to publish them in UiPath studio and copy the nuget Package from our test orchestrator to the prod orchestrator.
The packages from the deployment pipeline and from the UiPath Studio publish are different.
In the package from the UiPath Studio deployment you can find the folder lib with the DLLs- of the process/library and in the nuspec the targetFramework is net6.0-windows7.0. On the other hand, we have the Azure DevOps UiPath Extension build were is are no DLL files included and in the nuspec file the targetFramework is targetFramework is net5.0-windows7.0.
All together sounds like a problem with the build pipeline and the change from legacy to Windows.
We use to build the package the task “UiPath Pack” from the UiPath DevOps Extension since 2021. The build is made on a Self-hosted DevOps Windows agent were the newest Version of the Extension is installed 2.11.3214338 (Latest) and the agent has access to .Net Framework 6.

OnPrem Orchestrator Version: 2021.10.0
OnPrem Bot Version: 22.10.3

Any idea what’s the Problem here?

This more or less the same problem we have, our pipelines deploy but we cannot even run it.

I have no idea how to debug this sudden issue and we had diverted several projects to use the new process type specifically because it was indicated that we needed to, instead we have a deprecation scary-gram on every window and every attempt at upgrading has broken something

We have the same issue. No clue of how to fix it.

Same here, process not working at run stage

@alexandru Any idea? I wasn’t sure if this was something for you or rather the Orchestrator team.

I work with @Joshua_Rowlison and we have yet to resolve the issue. As Josh stated we have put a lot of work into getting everything flowing through the ADO Pipelines. Any updates or acknowledgement of the issue would be greatly appreciated.

1 Like

We’re having the exact same issue. So far only option is to publish via studio. We’ve delayed our migration to windows compatibility until this is resolved.

Sorry, I am very junior in UiPath programming but, how can we proceed then? I have create a new xaml within an old library that was use in a projects in the Legacy scheme. I have done the same: modify the xaml in the library and try to publish it so that I could use this xaml as an activity in my Legacy projects that used it. However, when I try to publish it, the system is throwing tones of validation errors of all projects I have, and concluding that I cannot publish the library project because I have all these validation errors. Can anyone help to find a way to get my library with my new xaml accesible for my old projects in Legacy system? I am about to loose many months of work!!!

Curious if there are any updates here or an ETA on when this might be fixed?

I had this problem as well. The issue for me was that the Build Pipeline was using the wrong version of the cli tool.

All we needed to do was add the UiPath Install Platform task in the Pipeline before the UiPath Pack task.

Select the latest Windows CLI version (Not Cross Platform or Windows-Legacy). Don’t worry about the input for the path to the CLI package.

Lastly, recreate the UiPath Pack task.

After that, you may get an error in the UiPath Pack task saying “##[error]Error packaging project: Error: Parameter ‘toolPath’ cannot be null or empty.”
The fix for this was that our projectJsonPath parameter for the UiPath Pack task was pointing to a folder that was one level above where the actual project.json file was. In previous Windows-Legacy project pipelines, this wasn’t an issue for us, but it seems that for this Windows CLI version, it needs to be the exact folder path.

I am facing the same issue and tried your advise to add UiPath install Platform but getting error like this:
installing platform: Error: end of central directory record signature not found.
Do you have any idea on my issue?

I have solved this problem by download UiPath.CLI.Windows.22.10.8438.32859.nupkg at https://uipath.visualstudio.com/Public.Feeds/_artifacts/feed/UiPath-Official

And put CLI.Windows.22.10.8438.32859.nupkg path at here:

So this is the step that I’ve done:

  1. Add UiPath Install Platform
  2. Choose CLI latest version
  3. Put windows CLI path at UiPath Install Platfotrm

Hope this help

Hi everyone,

we have meanwhile published a new version of the plugin supporting the packaging of modern projects.

Pls let me know if this has solved your problem or if further assistance is required.


For us it works fine since the latest plugin update.


What did you make your projectjsonpath? I used the install and am getting that error about the parameter ‘toolpath’. I tried many different possible paths but nothing seems to be working for me.


Is the solution just to be using the latest version of the integration plugin? Would that be version 3.0.3517186?

projectJsonPath: ‘$(Build.SourcesDirectory)\src’

My project ‘project.json’ file is inside my ‘src’ folder of my Git repository.
If your project isn’t inside any folders in your git repository, then it would just be ‘’$(Build.SourcesDirectory)'.

Thats how I had the parameter previously so I dont need to change anything but I am still getting that error.

My src is just the name of my project and inisde that folder is my project.json.

I finally got back to trying to get this to working again. I’ve got the new version of the cli working but for when I use version 3 of the UiPath Pack it always fails to authenticate to our orchestrator to restore custom nugget libraries. When I switch it back to version 2 it doesn’t fail to authenticate but also doesn’t build the nugget package correctly for the windows package. Anyone else experiencing this?

add .net version, it worked for me

1 Like