Troubleshooting UiPath Deployment Error in Azure DevOps: Assembly Load Failure

Hello,

I am facing an issue with the Orchestrator in Azure DevOps. Here are the specifics: After deploying the project to the production environment Orchestrator, I encounter this error when I try to run it.

It’s important to note that I do not receive this error when manually deploying and running the project. Here are the specifics:

Error Message:

Loaded page number 1 containing 10 items Job Details Process: AVI_U_Ibkb_Belge_Gonder Process Version: 1.0.161607094 Environment: Robot: bir004-unattended Account: bir004 Machine name: ANRUIRBTWX04 Info: Could not load file or assembly ‘UiPath.System.Activities, Version=23.10.2.0, Culture=neutral, PublicKeyToken=null’. The system cannot find the file specified.

System.IO.FileNotFoundException: Could not load file or assembly ‘UiPath.System.Activities, Version=23.10.2.0, Culture=neutral, PublicKeyToken=null’. The system cannot find the file specified. at AVI_U_Ibkb_Belge_Gonder.Main.GetImplementation() at System.Activities.Activity.OnInternalCacheMetadata(Boolean createEmptyBindings) at System.Activities.Activity.InternalCacheMetadata(Boolean createEmptyBindings, IList1& validationErrors) at System.Activities.ActivityUtilities.ProcessActivity(ChildActivity childActivity, ChildActivity& nextActivity, Stack1& activitiesRemaining, ActivityCallStack parentChain, IList1& validationErrors, ProcessActivityTreeOptions options, ProcessActivityCallback callback) at System.Activities.ActivityUtilities.ProcessActivityTreeCore(ChildActivity currentActivity, ActivityCallStack parentChain, ProcessActivityTreeOptions options, ProcessActivityCallback callback, IList1& validationErrors) at System.Activities.ActivityUtilities.CacheRootMetadata(Activity activity, LocationReferenceEnvironment hostEnvironment, ProcessActivityTreeOptions options, ProcessActivityCallback callback, IList`1& validationErrors) at System.Activities.Hosting.WorkflowInstance.ValidateWorkflow(WorkflowInstanceExtensionManager extensionManager) at System.Activities.Hosting.WorkflowInstance.RegisterExtensionManager(WorkflowInstanceExtensionManager extensionManager) at System.Activities.WorkflowApplication.EnsureInitialized() at System.Activities.WorkflowApplication.Enqueue(InstanceOperation operation, Boolean push) at System.Activities.WorkflowApplication.SimpleOperationAsyncResult.Run(TimeSpan timeout) at System.Activities.WorkflowApplication.BeginRun(AsyncCallback callback, Object state) at UiPath.Executor.RobotRunner.RunWorkflow() Start Time: 2/14/2024, 1:53:47 PM End Time: 2/14/2024, 1:53:53 PM Input Values: null Output Values: null Has Recording: false

Context:
After deploying the project to the production environment through Azure DevOps, I encounter this error when attempting to run it. It is important to note that this error does not occur when I manually deploy and run the project, which might be crucial for diagnosing the issue.

Environment Details: Azure DevOps Agent Version: 2.210.1 (On-premise)

Additional Details:
UiPath Studio Version: 23.4.5
UiPath Orchestrator Version: 23.4.2
Azure DevOps UiPath Extension Version: 4.0.4344497

Screenshots:

Has anyone encountered this error before or have any suggestions to resolve it?

Thank you in advance for your help!

We have solved this problem while updating our orchestrator and robot version then the problem was solved.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.