Could not find member 'CurrentIndex' in type 'http://schemas.uipath.com/workflow/activities:ForEach(String)'. Row: 95, Column: 64


#1

Hi,

I have problem to run the sequence as per below message.
Could not find member ‘CurrentIndex’ in type ‘http://schemas.uipath.com/workflow/activities:ForEach(String)’. Row: 95, Column: 64

Created the xaml file using Community 2018.3.0 and no issue.Then transfer the file to Enterprise 2018.2.4. However i cant run the program and appear error message as per below.
Could not find member ‘CurrentIndex’ in type ‘http://schemas.uipath.com/workflow/activities:ForEach(String)’. Row: 95, Column: 64

How to resolved this issue.
Thanks in advance.


#2

See this post

https://forum.uipath.com/t/uipath-core-activitiescannot-set-unknown-member-uipath-core-activities-foreachrow-currentindex/68811/3

You need to install UiPath.System.Activities and UiPath.UiAutomation.Activities, because UiPath.Core.Activities package has been split into these two.

Thanks,
Prankur


#3

Hi @azmee_zainol

UiPath workflows designed with the new community version 2018.3 cannot be run with an earlier version. This is due to internal changes. For example, some packages were decoupled and rethought and your older version will not understand those new changes.


#4

Hi @PrankurJoshi @loginerror

Thanks for the update.I have tried that but cannot update those package.
Pop up this message Unable to resolve dependency ‘Microsoft.Rest.ClientRuntime’

But i can run the program after did some tricky workaround.
Edit the xaml using MemoPad, and delete CurrentIndex="{x:Null}" in (2018.2.4 version).

:slight_smile:
Thanks again for your time.


Unable to match value from the excel cell to that in the drop down list on the website
#5

Thanks Azmee! Was facing the same issue while running a 2018.3 workflow in 2018.2.6. Your workaround made it work.
@UiPath team: understand that 2018.3 is a major version change but there should be at least backward compatibility to recent versions. A simple analogy being that you will expect MS Excel 2016 to be still able to open MS Excel 2012 files, right?


#6

We don t offer such kind of compatibility, yet.


#7

I come just to say that I have the same problem!
And thanks to your workaround!

BR
Helliton


#8

I don’t see this, where do find it? I am facing the same issue


#9

hello !
you can follow the below step:
open the Main.xaml with editPlus3 or other text editor.
find this sequence: CurrentIndex="{x:Null}"
and delete it
finally save the file.
finally finally open it and see if there is any surprise,
thanks


#10

I used Notepad to open Main.xaml, removed the tag, saved and my project worked.

Thanks for the heads up.