Unable to resolve dependency 'Microsoft.Rest.ClientRuntime'

Scenario: When running process, getting error in Windows Event Viewer saying:

{“message”:“System.InvalidOperationException: Unable to resolve dependency ‘Microsoft.Rest.ClientRuntime (≥ 2.3.10)’.\r\n at NuGet.InstallWalker.OnDependencyResolveError(PackageDependency dependency)\r\n at NuGet.PackageWalker.Walk(IPackage package)\r\n at NuGet.PackageWalker.Walk(IPackage package)\r\n at NuGet.InstallWalker.ResolveOperations(IPackage package)\r\n at UiPath.NuGetHotFix.PackageManager.Execute(IPackage package, IPackageOperationResolver resolver)\r\n at UiPath.NuGetHotFix.PackageManager.UpdatePackage(IPackage newPackage, Boolean updateDependencies, Boolean allowPrereleaseVersions)\r\n at UiPath.Project.ActivityPackageManager.InstallOrUpdatePackage(IPackage package, IPackage installedPackage, IPackageManager packageManager)\r\n at UiPath.Project.ActivityPackageManager.<>c__DisplayClass24_0.b__0()”,“level”:“Error”,“logType”:“Default”,“timeStamp”:“2018-10-02T13:30:22.7911706-07:00”,“fingerprint”:“acad7a2f-a928-4366-8ed6-4bcab8620295”}

Steps to reproduce:

Unsure, process ran fine this morning, however logs don’t appear in orchestrator anymore.
Was there an updated pushed?

Current Behavior:

Process running, nothing logged to Orchestrator.

Expected Behavior:

Run process e2e

Studio/Robot/Orchestrator Version: UiStudio 2018.1.4/UiRobot 2018.1.3/Orchestrator 2017.1.6547

Last stable behavior: This morning
Last stable version: Same
OS Version: Windows 10
Others if Relevant: (workflow, logs, .net version, service pack, etc):

We have been seeing this error for the last 2 days also. We get it in UiPath Studio when attempting to install the latest package updates. Several updates will not install because of this error.

I’m seeing this error today, when trying to install or update new packages. Appreciate any the help to resolve this.

Seeing this in Studio 2018.2.3 and 2018.2.4 also

I had this problem today in a new installation of UiPath.

While trying to install UiPath.Framework.Activities a message about Microsoft.Rest.ClientRuntime dependency appeared.
I have solved my problem by downloading the nuget package, and installing manually into UiPath, through the Package Manager.


My problem was that the available packages are 2018.3.x, and we are running Studio v2018.2.3, so we can not yet update to the 2018.3 package versions (just don’t update and you should be fine). Once we upgrade to Studio 2018.3, we’ll get the 2018.3.x packages.


It worked like a charm. Thank you for your contribution!

I am getting the same error in Studio 2018.1.5. I’m unable to add the nuget package manually because I don’t have admin privilege.